Resizing IDE Window Crashes IDE

On my desktop, I have RStudio version 1.3.1056 and R version 4.0.2. For some odd reason, whenever I use my cursor to resize the window, RStudio disappears completely from sight and Rstudio crashes (or at least that's my assumption, given that the process ends.) A Windows crash message does not appear. I am unable to maximize the window as well. How can I fix this? Thanks!

Edit (4:10 EST): I have undownloaded RStudio, deleted all the files, including in the Local App Data, and then downloaded the newest version of RStudio. It still crashes when the window is resized.

This, by it's very nature, is a nearly impossible problem to solve remotely. It'll never be reproducible by anyone who could help and it could be the result of a million different things that have nothing to do with R or R Studio.

That said...

You said you deleted the Local App Data, so I'm inferring you're on a Windows PC rather than OSX or Linux. Correct me if I'm wrong, and in the future it's almost always hhelpful to be up front about that.

When you open R Studio is there anything loaded? A project or documents? And plots in the viewer pane? Or is it a bone standard, stock load?

What happend when you minimize or maximize the R Studio window?

Does anything happen when you use the cursor to move the window around rather than re-sizing it?

How much RAM do you have on your machine?

If you look at the Performance tab in the Task Manager are you low on resources?

Do you have any pending Windows Updates you've been putting off?

Have you tried re-booting your PC?

I think It is possible that this might be related to a video driver incompatibility. Have you tried changing to software rendering?, you can change it by holding the Ctrl key while opening RStudio, then you should see this menu and change the "Rendering Engine" to "Software".


:clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap:
Hot damn! That's new to me!
No more opening R Studio, changing the R version, closing it, then re-opening it for me!
:clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap:

Ah, that's true!

I am indeed a Windows user; I'm on Windows 7 because I don't like Cortana. There was nothing loaded; a bone standard, stock load. Maximizing the window also crashes it, but minimizing does not. Using my cursor to move the window does not crash it. I have 8 GB of RAM, and I am only using ~40% of the resources, including RStudio. The problem persists with Windows Updates and re-booting my PC.

Oh wow, I would have never guessed that this was the issue! Thank you for solving my problem!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.