Pop-Up Error: Unable to establish connection with R session

First, try this, it's my new go to suggestion for anyone with weird R Studio behavior,

After that, the art of asking for help is, in fact an art. There are so many variables present in a modern computer it's impossible for anyone to know which combination of a thousand possible things could be the culprit when something like this happens. So the more information you give the better.

Here are a few things off the top of my head which might help the right person know how to help you better:

  1. What operating system are you using?
  2. What version of R Studio?
  3. What version of R?
  4. Does the interface load completely, partially, or not at all?
  5. When you open R Studio is it trying to load a project, restore a workspace, or is it a clean open?
  6. Did R Studio perviously work without issue on the same machine?
  7. Have you tried rebooting your computer?
  8. How did you install R Studio? Download it from the website or with some kind of package manager?
  9. Did you install any other software between the last time R Studio worked and now? What was it?
  10. Is your system a multi-user system? That is are there other user accounts on it and does R Studio work for any of them?
  11. Have you edited any of the R Studio configuration files recently (or ever).
  12. When you installed the software (R and/or R Studio) did you install it in the default location or did you point out to somewhere else?