Fresh Install keeps freezing a few minutes after startup

I have installed rstudio on a windows 10 computer. However`a few minutes after loading up RStudio freezes and becomes unresponsive. I have tried a few different things from several other help menus but nothing has seemed to work yet. Any thoughts?

Error Information:

Description of issue -
Freezing on startup
Attempted steps taken to fix -
I have tried uninstalling and reinstalling.
I tried installing an older version of Rstudio
I have tried changing the rendering engine.

System Information:

  • RStudio Edition: (Desktop or Server)
    Desktop RStudio-1.1.463
  • RStudio Version:
  • OS Version:
    Windows 10 Pro version 1903
  • R Version:
  • Output your diagnostics report (if possible):

From RStudio Desktop Will Not Start on

It looks like you're using an older release of RStudio (v1.1.463). Do you have better luck with the latest v1.2 release of RStudio?

I tried both versions and both freeze. I am currently running version 1.2.1335. When I originally typed this the program had frozen so didn't look at the 'RStudio About help menu' .Glanced at my download files and wrote down the wrong one :-/

Do you have any better luck if you reset RStudio's state?

Just tried this. Still freezing after just a few moments. It seems to freeze about 30 seconds after loading up. This is with just pulling up and going through menus.

Does the IDE freeze in response to some specific action, or does it seem to occur at any time? Does the entire IDE freeze (e.g. you cannot even type text into the Source editor), or just the R console becomes unresponsive?

As a long shot, does switching to software rendering make a difference?

It is definitely the IDE that freezes and not just the R console. I have changed the render type a couple of times and it seems like it might make a little difference but ultimately it still freezes. It freezes not form what specific command. It is me just literally looking at the drop down menus.

Here is a video of it freezing. I tried this after deleting the appdata.

That is very weird! We haven't seen this before :-/

There are similar state folders, located at:


Does deleting either of these make a difference?

If you open the Task Manager, does it show the RStudio process as hanging? Is it stuck at 100% CPU, or just doing nothing?

Do you have any better luck with the daily builds of RStudio? (seems unlikely, but worth a try)

I deleted the other appdata folders and restarted and still the same thing. I also retried after doing this by changing the rendering engines again and still same thing. When you go to task manager to close out RStudio it list the CPU usage at 0%. WIll try the daily build next.

Still the same thing using the most current daily build.

It seems like a long shot based on everything you've done, but have you tried installing R/RStudio as an administrator? This issue sounds at least nominally similar, and that's what fixed the freezing problem for the OP there.

So unistalled R and RSTUDIO then deleted appdata...then re-installed as admin...and then ran RStudio as admin....still same issues.

Darn. Thanks for taking the time to test. At this point, I don't have any good ideas on what the issue could be :-/

Some things that could be worth exploring:

  • Do you have an antivirus / antimalware application running? Does disabling it make a difference?
  • Are there any other background applications running that might potentially be causing issues?

Okay I think I finally got this thing working. I started to disable background applications and testing to see if Rstudio would stop freezing. Apparently, an application called Nahimic by MSI ( a program designed to boost audio quality for gamers) when disabled would allow RStudio to not freeze. I rebooted 4 or 5 different times and everytime I disabled this program RStudio would work and if I didn't disable it RStudio would freeze. Have no idea why this program created a conflict. But Hoorah for finally figuring this out. It was driving me mental health can be restored. lol.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.