Trouble configuring RStudio to use repos from RSPM

I'm getting an error message when attempting to configure RStudio Server to use the any of the repos from Package Manager. When I try to enter the url of any of the PM repos, I get an error message saying that the url is invalid (See image).

Thanks for trying out the QuickStart!

To use the repositories in RSPM from the QuickStart, you can navigate to the "Setup" page for a given repository to view the repository URL that you should use in the RStudio IDE packages configuration dialog:

You will see that you should add /latest to the end of your repository URL, so that it becomes:


which behaves as a valid CRAN repository.

Or in the case of other repositories such as the CRAN mirror, you can choose either the latest package (e.g., http://localhost:5000/packages/curated-cran/latest) or a fixed set of packages from a particular checkpoint/date (e.g., http://localhost:5000/packages/cran/151).


Ahh, I see. Thank you. As for the checkpoint number, is that the Id from the activity tab in RSPM?

Yes, the checkpoint number corresponds to the transaction ID that shows up in the Activity tab in RSPM, as described in

From my experience (see my comment in the other thread linked below), one more step is still needed to get QuickStart IDE to install packages from QuickStart RSPM: Uncheck the "Use secure download method" box. If you don't do this, access/installation will fail because IDE will require that the repo URL be https, and the localhosted QuickStart RSPM does not offer that.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.