The Git tab has disappeared?

This is very strange.

I have Git setup and suddenly the Git was gone from my project.

So I looked at the global options which looks like this

Clearly, the Git.exe is there

However, when I check the project's Git. I see that Git is not there!

This is very strange! So I tried to see if it's to do with my project, so I tried to start a new project

So what should I do now? I have tried to re-install Git, reinstall Rstudio, restart Rstudio and restarting. Still no luck? The directory is still a git directory as I can git status it no problems, and I use other git clients to see that the git/project directory has no issues.

The only I did do was to install Anaconda. Could that be causing the issue? How do I hard reset RStudio IDE? I.e. delete all folders and start again?

Actually, it's also not recognising the RTools I have installed as well!

What is the output of:

writeLines(strsplit(Sys.getenv("PATH"), ";")[[1]])

I wonder if installing Anaconda also placed some utilities on the PATH that is interfering with the way RStudio discovers Git and other tools.

You could also check what the output of:


to see if git is indeed available on the PATH (and so could be discovered by RStudio)

In addition, you can try resetting RStudio's state: and see if that makes a difference.

Thanks. I had to reset Windows to make it work.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.