Tab is focusing on next clickable item in Rstudio Server

Hitting tab in R-studio server has started to switch the focus to the "next clickable item" instead of tab-complete or creating spaces. This is happening on the editor/console/terminal and just started today.

Some notes:

  1. I'm on a Mac and the server is on an AWS EC2 ubuntu instance.
  2. I tried both Chrome and Safari and they both have the same problem.
  3. I opened up Jupyter-lab and this is NOT happening.
  4. "Use tab for autocompletions" is checked in Options -> Code -> Completion.
  5. I tried restarting the ec2 instance, my computer, updating Rstudio-server and updating chrome.

I can't seem to find the right browser setting or Rstudio setting or find anything online. Any help would be great.

Some screenshots are included. The only difference between the first and second is hitting Enter and tab. Instead of created spaces, the focus moves to the history pane below.


1 Like

Well, I resorted to the "burn-it-all-down" solution and it worked. :firecracker: :fire:

I must have inadvertently changed some option...but could not figure out which :man_shrugging:

I believe resetting the Global options (via moving ~/.config/rstudio/) is what did it...but I moved all of the suggested directories

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.