ShinyApps not deploying

Hello! I'm attempting deploy my Shiny, and I keep getting this error message.

I'm not sure exactly what the issue is. In some of the files I'm reading it in, there are German characters (i.e. characters with Umlaut, e.g: ä). I'm fairly sure that this is the issue, as I've meticulously gone through the rest of my code to make sure it doesn't have the standard deployment errors.

Does anyone know if theres a good work-around to this?

You could try this proposed solution

Hi @andresrcs.

I have narrowed it down to the multi-byte issue

Do you know if this is a UTF-8 issue? And, if so, do you know if can only be multibyte characters in the r-script, or if it also includes multibyte characters in the excel files I read into the Shiny app?

The issue on the post I have linked is with multi byte characters also, and that solution was proposed by an RStudio employee so I would give it a try to see if it works

Yeah, I've tried working through their solutions and it hasn't worked yet. I'll keep looking though - thanks for the pointer either way!

So for anyone who might be following along, I've managed to figure it out. Instead of using read_csv, I simply use read_excel. That's solved all issues.