RStudio won't load at office

RStudio was working fine on my regular machine at the office. At one point, last week, while I was working at the office, it stopped working, as in RStudio starts, but everything is blank, it won't connect to R, and I just get the STOP sign, like it's trying to load.
Bypassing RStudio, I can still get regular R to work, with RGui. But of course I'd much rather work in RStudio.
Now, this may be a coincidence, but when I was working from home last week, everything functioned fine. But when I returned to the office, I am now experiencing the same issue, so I'm not sure if there's some network issue.
When I run a diagnostics report, i get the following as the first error (there are lots more errors, but they're mostly the same error as this one).

10 Sep 2019 16:24:51 [rsession-barmstrong] ERROR system error 10053 (An established connection was aborted by the software in your host machine) [request-uri=/events/get_events]; OCCURRED AT: void __cdecl rstudio::session::HttpConnectionImpl::sendResponse(const class rstudio::core::http::Response &) c:\jenkins\workspace\ide\windows-v1.2\src\cpp\session\http

Update: I tried to completely unhook my office connection and restarted my machine and tried to run it. Still didn't work (same error). So maybe the office/home thing is a coincidence. Still not sure why it would work, then not work, then work, and then not work.

This is very likely the work of a firewall or antivirus software on your machine. If you're running something of that nature, you may need to add an exemption to RStudio so that it can talk to R successfully.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.