RStudio won't detect Firacode on Ubuntu 20.04

Related to these 3:

I've installed Firacode using every method I can find, but RStudio can't detect it (It's not available in Tools -> Global Options -> Appearance). I've tried all the fixes in the three links above, but nothing has worked. I've restarted RStudio and my computer. fc-list | grep "fira" returns the path to several OTF files in /usr/share/fonts/opentype/firacode

Any help is greatly appreciated! I'm working on reading through the RStudio source code to see where fonts are loaded, but I don't know java, so it's been slow. If anyone has found another way to get this to work, I would love to hear it!

What worked for me with the JetBrains Mono font (also couldn't get it to work) is that I installed a different version of it that didn't include ligatures and then RStudio detected it with no problem.

1 Like

Thanks for the response! I'm mainly trying it out to see how I like the ligatures, so I'm really hoping to find a solution that keeps them. But I do like the font itself, so maybe I will still try it out. Thanks again! :v:

Do you also see this issue with the current preview release?

If so, would you mind filing this as a bug report at, so we can try to investigate further?

1 Like

For extra context, this is where we build the list of fonts to be used by RStudio:

So, the output of the following would likely be helpful:

fc-list :spacing=100 -f '%{family}\n' | cut -d ',' -f 1 | sort | uniq
1 Like

Thank you, Kevin! I appreciate the context, and I will check the preview release and file the issue.

$ fc-list :spacing=100 -f '%{family}\n' | cut -d ',' -f 1 | sort | uniq
Courier 10 Pitch
DejaVu Sans Mono
Liberation Mono
Mitra Mono
Nimbus Mono PS
Noto Color Emoji
Noto Mono
Tlwg Mono
Tlwg Typo
Ubuntu Mono

While working on filing this issue, I actually found this one:

It looks like Fira Code is being filtered out by the :spacing=100 step.

$ fc-list :spacing=90 -f '%{family}\n' | cut -d ',' -f 1 | sort | uniq
Fira Code

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.