RStudio window behaves as if it is invisible

Error Information:

When I launch RStudio from either the taskbar or start menu, the icon on the taskbar lights up as if it has opened but I cannot see a window.

When I tell my computer to pane the windows sideway/stacked with only RStudio and one other app open, half the screen is blank so it's quite literally as if the window is invisible. When I hit Win+Tab I can see it among the active windows but selecting it, or even trying to drop it to a second desktop does not resolve the issue. I tried cascading windows and it shows a gap as if there is a window there but agian it is literally just invisible. Win+arrows doesn't help either.

I've tried restarting my machine but that didn't help. I reinstalled RStudio and that didn't help either.

I worked through the solutions on this link and none helped. I've tried opening .R files in two different directories after deleting .Rhistory files in both and neither worked. Sys.which("R") in the second section yielded this result ("C:\PROGRA~1\R\R-35~1.3\bin\x64\R.exe") but I don't understand what I'm supposed to do with that. I tried resetting the state by renaming both folders and that didn't help either. I also tried using ctrl+click to launch each of the three 3.5.1, 3.5.2, and 3.5.3 versions that I have installed and none of those helped.

System Information:

  • RStudio Edition: 3.5.3
  • RStudio Version: RStudio 1.2.1335 - Windows 7+ (64-bit)
  • OS Version: Windows 10
  • R Version: 3.5.3
1 Like

Does switching to software rendering make a difference? See for more information.

I tried the right click on start to get the dialogue box which did show up. I switched from Auto detect to Desktop OpenGL and to Software, on two different versions of R (3.5.3 and 3.5.1) and neither did anything different.

I did have a rendering issue before which was in a previous post of mine but I was able to fix that. Trying this time didn't help.

I just found this thread which describes my problem exactly. It appears to be unanswered.

Can you also let us know what kind of system you're running on?

Do you see the RStudio process (or its child process, QWebEngineProcess) also running and taking up lots of CPU when RStudio is launched?

Does deleting any of these folders make a difference?


A colleague helped me resolve the issue. I had to hover my mouse over the RStudio icon on the taskbar until the preview popped up. When I moved up to hover over that I was able to right click and select maximize which brought the window back.

I don't really understand what happened because if it was simply the case that the window was minimized, then win+arrows, cascade windows, or tile windows should have brought it back. It also doesn't explain why when, for example, I selected cascade windows that it "skipped" a step and acted like a phantom window was there, or when I had two windows open (chrome + RStudio) and selcted "show side by side" it put chrome on the left half and the right half showed the desktop.

Regardless, multiple people have clearly had the same problem so I wanted to be sure to post my answer for others having the same problem in the future. I felt like I was in xkcd 979, so now hopefully the next person won't feel the same way.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.