RStudio themes dont work as expected in newer RStudio versions


I am trying to use the Dracula RStudio theme (, but it doesn't work in newer RStudio versions. Here is a screenshot with RStudio version 2021.9.2.382

This works (except the code colors aren't as shown in the example image, but that's another issue probably.) Here is a screenshot with RStudio version 2022.2.0.423

The text editor and console look as they did with the previous version, but other aspects of the GUI look completely different. Is this something that should be fixed in the theme, or an RStudio issue?


I don't have a solution to this problem, but would be interested in knowing if you find one. Did you ever manage to find a solution?

I believe the theme file format evolved a bit with one of the RStudio updates.

We (okay, I) broke this unintentionally when removing RStudio's Classic theme; it turns out a lot of third party themes had grown to rely on a selector we removed. I've just fixed it yesterday in +442 -- give it a try?

1 Like

Updating to RStudio 2022.02.0+442 "Prairie Trillium" fixed it. Thank you very much.

Great, glad to hear it!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.