RStudio slow to start and randomly irresponsive


Since recently, RStudio is very slow to start and hangs randomly, e.g. when I'm typing. It's pretty much the same problem as in this closed topic:

I tried shutting down all the other apps running on my desktop (OS Windows 7 Professionnal 64-bit), one at a time. I also rebooted my PC, I tried deactivating RStudio options that I thought could be involved (rendering, packages panel, publishing, etc). All my libraries and projects are on a local disk.

Only 2 things fixed the problem:

  1. If I disconnect the internet. This is not a viable solution to me, no more than disabling my firewall and/or anti-virus. I'm in government and they are both controlled by IT, who would never let that happen.

  2. If I install an old version. I tried installing/uninstalling these past versions, in that order:


The problem went away at version 1.1.383. What has changed in the following versions? There must be some internet-related stuff going in the background that didn't exist in version 1.1.383. Also, since I started to experience these problems only recently although I've used all the other versions before without problems, I suspect my firewall settings must have been changed by ITs with one of their monthly updates. Is there a port or domain RStudio uses in the background and that I can ask IT to unblock?

My version of R is 3.6.1

Thanks a lot in advance.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.