RStudio Server Ubuntu 20.04

Hi all,

I am trying to install RStudio Server on my newly installed Ubuntu 20.04 machine, but I am running into issues.
I managed to install R version 3.6.3, as well as RStudio Desktop, both 1.4.294-amd64, (nightly release) and 1.2.5042-amd64 (stable).

When trying to install RStudio Server, using either versions :
- sudo gdebi rstudio-server-1.4.294-amd64.deb
- sudo gdebi rstudio-server-1.2.5042-amd64.deb

I am running in the following error:
Process: 4313 ExecStart=/usr/lib/rstudio-server/bin/rserver (code=exited, status=127)
or sometimes
Process: 5601 ExecStart=/usr/lib/rstudio-server/bin/rserver (code=exited, status=127)
mai 02 15:09:33 Mortimer systemd[1]: rstudio-server.service: Control proces…/n/a
mai 02 15:09:33 Mortimer systemd[1]: rstudio-server.service: Failed with re…de'.
mai 02 15:09:33 Mortimer systemd[1]: Failed to start RStudio Server.

I couldn't find any information on the internet regarding this error.
Has anyone managed to get RStudio Server working on an Ubuntu 20.04 machine ?
Or has anyone ever encountered such an issue and could help me ?
I am quite new to RStudio Server and Linux. I am trying to set up a spare computer as a Linux based RStudio Server to help me with my projects as I am working from many different places and computers.

Best regards,


Unfortunately Ubuntu 20.04 is not yet on the supported platform list.

Can you try the installation on Ubuntu 18.04 instead?

Maybe I'm just lucky, but I have RStudio Server 1.3.947 running on Ubuntu 20.04, and so far no problems. I started with the "server" install of Ubuntu, not desktop, so I don't know if that has anything to do with it. I also used apt to install, and made sure that I had the prerequisite R packages and any dependencies beforehand.

I also cannot install RStudio Server 1.2.5042 doesn't install on my WSL Ubuntu 20.04; seems it is not compatible. But I get a different error:

/usr/lib/rstudio-server/bin/rserver: error while loading shared libraries: cannot open shared object file: No such file or directory

I have installed the latest version of libssl-dev and libssl1.0.0 is unavailable with the following error:

Package libssl1.0.0 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

It seems RStudio Server 1.3.947 is a professional version not available to the general public (or am I wrong? I can't find a download link, only a user manual that doesn't contain installation instructions for rstudio server itself). I use RStudio Server to run RStudio in my WSL (which doesn't have a GUI - so I run RStudio in my browser). Is there any other solution for me until Ubuntu 20.04 is supported? Thanks!

RStudio v1.3 has not yet been released, but preview releases are available here:

Hi I have installed rstudio-server pro on lubunutu 20.04. I had no issues during install but i cannot login to the actual webinterface. Whenever I enter my username and pw it does not login. If I enter the correct username and pw it just reloads the login page, if I enter a wrong username or wrong password i get the usual notification that username and/or pw are wrong.

pamtester does not show any issues.

So rstudio server recognizes the login credentials, but does not forward to the actual interface.

The same happens when i want to get to the admin page ip-address:8787/admin

Any ideas?

I solved the issue. It was a missing Java installation on the server.

1 Like

had issues getting rstudio-server running on fresh install of 20.04 -- installing depreciated libssl1.0.0 package from prev. version of ubuntu got it working for me.

1 Like

This is what I was searching for. Can you please publicise this on the rstudio downloads page?
rstudio downloads page

I have the same problem as yours, Is there any solution for it?

my R session from R console:

R version 4.0.1 (2020-06-06)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 20.04 LTS

Matrix products: default
BLAS:   /usr/local/lib/R/lib/
LAPACK: /usr/local/lib/R/lib/

Random number generation:
 RNG:     Mersenne-Twister 
 Normal:  Inversion 
 Sample:  Rounding 
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=en_GB.UTF-8        LC_COLLATE=en_US.UTF-8    
 [7] LC_PAPER=en_GB.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_4.0.1

I used to have rstudio server running on ubuntu 18.4 and now when I:

sudo rstudio-server verify-installation

/usr/lib/rstudio-server/bin/rserver: error while loading shared libraries: cannot open shared object file: No such file or directory

Is there literature available for compiling this on 20.04?

Heck yeah! Finally! Thank you for this.

I had the same issue:
"error while loading shared libraries: cannot open shared object file: No such file or directory"

Using the link by ahasvuerus -

sudo apt install ./libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb

And finally, after that you can install the rstudio-server-1.3.959 version

@mohammadreza , I see that your error is looking for libssl1.0.2. If you download 1.3.959 server version I think you'll be good to go :slight_smile:


Can you elaborate this a little? Are you hinting on the sequence, i.e. if we first instal Rstudio by mistake and then install Rstudio server then the server installation is likely to fail? Since you say you directly installed rstudio-server and it worked. We may be needing your help please. We are unable get Rstudio server up on ubuntu 18, not to mention ubuntu 20 and you have it working on ubuntu 20 in the first shot.

I am getting the exact same error even on ubuntu 18.

$ sudo gdebi rstudio-server-1.3.1056-amd64.deb
Reading package lists... Done

Building dependency tree

Reading state information... Done

Reading state information... Done

RStudio Server

RStudio is a set of integrated tools designed to help you be more productive with R. It includes a console, syntax-highlighting editor that supports direct code execution, as well as tools for plotting, history, and workspace management.

Do you want to install the software package? [y/N]:y

(Reading database ... 212726 files and directories currently installed.)

Preparing to unpack rstudio-server-1.3.1056-amd64.deb ...

Unpacking rstudio-server (1.3.1056) over (1.3.1056) ...

Setting up rstudio-server (1.3.1056) ...

useradd: user 'rstudio-server' already exists

Created symlink /etc/systemd/system/ → /lib/systemd/system/rstudio-server.service.

Job for rstudio-server.service failed because the control process exited with error code.

See "systemctl status rstudio-server.service" and "journalctl -xe" for details.

● rstudio-server.service - RStudio Server

Loaded: loaded (/lib/systemd/system/rstudio-server.service; enabled; vendor preset: enabled)

Active: activating (auto-restart) (Result: exit-code) since Tue 2020-07-21 09:50:14 UTC; 99ms ago

Process: 3061 ExecStart=/usr/lib/rstudio-server/bin/rserver **(code=exited, status=127)**


$ systemctl status rstudio-server.service
**●** rstudio-server.service - RStudio Server

Loaded: loaded (/lib/systemd/system/rstudio-server.service; enabled; vendor preset: enabled)

Active: **failed** (Result: exit-code) since Tue 2020-07-21 09:50:14 UTC; 28min ago

Process: 3061 ExecStart=/usr/lib/rstudio-server/bin/rserver **(code=exited, status=127)**

rstudio-server.service: Service hold-off time over, scheduling restart.

rstudio-server.service: Scheduled restart job, restart counter is at 5.

Stopped RStudio Server.

**rstudio-server.service: Start request repeated too quickly.**

**rstudio-server.service: Failed with result 'exit-code'.**

**Failed to start RStudio Server.**

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.