Rstudio Server - Outdated dependency


I am trying to install rstudio-server-1.2.5042-amd64.deb on Debian 10 Buster, however, I receive the following error:

Process: 2651 ExecStart=/usr/lib/rstudio-server/bin/rserver (code=exited, status=127)"

When I try to start /usr/lib/rstudio-server/bin/rserver, I receive the following error:

/usr/lib/rstudio-server/bin/rserver: error while loading shared libraries: cannot open shared object file: No such file or directory

Searching for*, I find I tried creating a symbolic link from to, but then I received a similar error regarding a missing Searching for this file, I find Creating a symbolic link
to this and then rerunning /usr/lib/rstudio-server/bin/rserver yields:

/usr/lib/rstudio-server/bin/rserver: /lib/ version OPENSSL_1.0.0' not found (required by /usr/lib/rstudio-server/bin/rserver) /usr/lib/rstudio-server/bin/rserver: /lib/ version OPENSSL_1.0.0' not found (required by /usr/lib/rstudio-server/bin/rserver)

The missing files are part of the openssl package. Searching debian for versions of openssl with apt policy openssl yields:

apt policy openssl
Installed: 1.1.1d-0+deb10u3
Candidate: 1.1.1d-0+deb10u3

rstudio-server-1.2.5042-amd64.deb is the latest version available and I have tried installing it with

sudo gdebi rstudio-server-1.2.5042-amd64.deb
sudo apt install rstudio-server-1.2.5042-amd64.deb
sudo aptitude rstudio-server-1.2.5042-amd64.deb

It appears to me that rstudio-server-1.2.5042-amd64 is looking for an outdated version of openssl.

Is there a workaround until this is fixed?

Please note this issue is also raised with respect to the Ubuntu environment. See RStudio Server Ubuntu 20.04

Rstudio is not the only one to continue to rely on an obsoleted and unavailable version 1.0.0 of openssl. See That was back in 2018.

I even adapted the first solution offered by matlab. It did not work.

So, does anyone have a workaround?



Hi All,

I found the workaround.

The preview version 1.3.959 works. This can be found at:

or downloaded with:


I don't like running beta versions of software in a production environment, so I only take this as a workaround, not a proper solution.



This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.