RStudio Server redirect to login page upon signin (1.4.1106 only)

Running RStudio Server with default settings on a remote Ubuntu instance (Ubuntu 18.04.5 LTS). Up until version 1.3.1093, everything worked fine. However, since upgrading to the latest version 1.4.1106, I am being redirected to the login page whenever I try to sign in. Note that their is no message along the lines of 'username/password invalid' showing up - just the blank login page. Going back to 1.3.1093, login works again upon first trial.

Has this been reported before? I haven't changed anything in my setting, which leaves me somewhat puzzled right now. Please let me know if you require further details regarding my setup.

For the record, I already tried with renaming folders ~/.local/share/rstudio and ~/.config/rstudio as suggested here, but didn't have any success either.


I experiment the same behavior with Ubuntu 20.04 LTS on an AWS EC2 instance, some times it takes more than three attempts to log in and some times just logs in at the first try, that is why I suspect it is related to the latency of the internet connection on the client side.

1 Like

Also using AWS EC2. In my case, the "some times [...] more than three attempts" part applies to version 1.3.1093, which I figure is okay. However, with 1.4.1106, I've tried it 50+ times with a 0% success rate so far :thinking:


Adding my experience to this. I'm having a similar issue with 1.4.1106 (also checked with 1.4.1103 and same experience). However, I have a slight wrinkle: when I connect directly on port 8787 is works fine and I can login reliably. However, when I try to connect via an SSH tunnel I get stuck in the same login cycle you describe.


Can also confirm that 1.3.1093 works fine over an SSH tunnel.

So this feels like it's an issue with more recent versions.

Unfortunately, I have to connect via an SSH tunnel due to company policy. I'd highly appreciate if this could get fixed, otherwise it's a major drawback.

Exact same issue here using 1.4.1013 (Wax Begonia) for Ubuntu Bionic using R version 4.0.2 on Platform: x86_64-pc-linux-gnu (64-bit), Running under: Ubuntu 20.10.

It often takes multiple tries to login. When it fails, it fails silenty and redirects to the empty log-in page with no error displayed. After enough trying sometimes it suddenly works. Also trying to authenticate using an SSH tunnel (company policy)

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.