RStudio preview 1.2.637 and 1.2.792 do not start on Linux Mint Guest in VirtualBox


I am having an issue starting Preview 1.2.637 (not sure about previous version) and 792:
I have been using RStudio desktop on Linux Mint Guest (Windows 7 host) since several years throughout different versions of both RStudio itself as well as the OS.
I recently tried to update to the preview 1.2, but it does not start. this problem occurred both in Mint 18.3 and yesterday I updated to 19 and the problem persists.
On start, if I run it from command line, I can see it throws the following error:
OpenGL Warning: vboxCall failed with VBox status code VERR_BUFFER_OVERFLOW

OpenGL Warning: glXCreatePbuffer not implemented by Chromium
[27400:27455:0712/104645.105863:ERROR:gl_surface_qt.cpp(278)] glXCreatePbuffer failed.
Received signal 11 SEGV_MAPERR 000000000000
#0 0x7f31b55c30a5
#1 0x7f31b4304141
#2 0x7f31b55c343d
#3 0x7f31b39eb890
#4 0x7f31b434587b
#5 0x7f31b43463f7
#6 0x7f31b609b674
#7 0x7f31b442acbb
#8 0x7f31b442c551
#9 0x7f31b756cb00
#10 0x7f31b561af0d
#11 0x7f31b56164ad
#12 0x7f31b39e06db start_thread
#13 0x7f31b1eeb88f clone
r8: 0000000000000000 r9: 0000000000000000 r10: 00007f312c0008d0 r11: 0000000000000000
r12: 00007f3168ff87f0 r13: 00007f3168ff8830 r14: 00007f3168ff8710 r15: 00007f31b43457f0
di: 0000000000000000 si: 000055ca2657ef00 bp: 00007f3168ff8550 bx: 00007f312c0035a0
dx: 0000000000000021 ax: 00007f31ba1a7570 cx: 00007f3168ff8380 sp: 00007f3168ff8380
ip: 00007f31b434587b efl: 0000000000010206 cgf: 002b000000000033 erf: 0000000000000004
trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.

installation occurs with no problems, after installing libclang-dev (6.0 in my case)

Any suggestion?


We've had a number of crash-on-startup issues reported by users with Windows laptops containing certain onboard Intel graphics cards. See Preview Release 1.2.747-3 Doesn't open on Windows 10 for more details.

Is it possible that you're running into some manifestation of the same problem?

Hi Kevin,

thanks for the prompt reply.
The host computer is running windows 7, not 10. The operating system RStudio IDE is running on is Linux Mint, as virtualbox appliance, and the graphic card on the computer is an NVidia Quadro K4200.
I hope this helps.


I am getting a similar startup issue on Ubuntu 16.04 running Cinnamon desktop.

$ rstudio
QApplication: invalid style override passed, ignoring it.
WebEngineContext used before QtWebEngine::initialize() or OpenGL context creation failed.
Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::SwapBehavior(DefaultSwapBehavior), swapInterval 1, colorSpace QSurfaceFormat::ColorSpace(DefaultColorSpace), profile  QSurfaceFormat::OpenGLContextProfile(NoProfile)) 
Received signal 6
#0 0x7f98d65600a5 <unknown>
#1 0x7f98d52a1141 <unknown>
#2 0x7f98d656043d <unknown>
#3 0x7f98d4989390 <unknown>
#4 0x7f98d2e6b428 gsignal
#5 0x7f98d2e6d02a abort
#6 0x7f98dd12005e QMessageLogger::fatal()
#7 0x7f98cef6b9e6 <unknown>
#8 0x7f98cef6bd22 <unknown>
#9 0x7f98cef6ded6 QQuickWidget::resizeEvent()
#10 0x7f98db7b87ad <unknown>
#11 0x7f98dc9787b2 QWidget::event()
#12 0x7f98cef6e84b QQuickWidget::event()
#13 0x7f98db7b89f6 <unknown>
#14 0x7f98dc93b63c QApplicationPrivate::notify_helper()
#15 0x7f98dc942987 QApplication::notify()
#16 0x7f98dd308028 QCoreApplication::notifyInternal2()
#17 0x7f98dc970f22 QWidgetPrivate::sendPendingMoveAndResizeEvents()
#18 0x7f98dc974a13 QWidgetPrivate::show_helper()
#19 0x7f98dc9749b7 QWidgetPrivate::showChildren()
#20 0x7f98dc974a2f QWidgetPrivate::show_helper()
#21 0x7f98dc977b65 QWidget::setVisible()
#22 0x7f98dc9749c8 QWidgetPrivate::showChildren()
#23 0x7f98dc974a2f QWidgetPrivate::show_helper()
#24 0x7f98dc977b65 QWidget::setVisible()
#25 0x562a86cd7f8d <unknown>
#26 0x562a86cd8fcb <unknown>
#27 0x7f98dd334181 QObject::event()
#28 0x7f98dc93b63c QApplicationPrivate::notify_helper()
#29 0x7f98dc942987 QApplication::notify()
#30 0x7f98dd308028 QCoreApplication::notifyInternal2()
#31 0x7f98dd30aabb QCoreApplicationPrivate::sendPostedEvents()
#32 0x7f98dd35cb63 <unknown>
#33 0x7f98d04b2497 g_main_context_dispatch
#34 0x7f98d04b26f0 <unknown>
#35 0x7f98d04b279c g_main_context_iteration
#36 0x7f98dd35c1af QEventDispatcherGlib::processEvents()
#37 0x7f98c6e47b81 <unknown>
#38 0x7f98dd30689a QEventLoop::exec()
#39 0x7f98dd30f424 QCoreApplication::exec()
#40 0x562a86cab549 <unknown>
#41 0x7f98d2e56830 __libc_start_main
#42 0x562a86caed3b <unknown>
  r8: 0000000000000049  r9: 00007f98dd94e940 r10: 0000000000000008 r11: 0000000000000202
 r12: 00007ffd973d2b00 r13: 0000562a88ddf060 r14: 0000562a8890ffc0 r15: 00007ffd973d3080
  di: 00000000000086e9  si: 00000000000086e9  bp: 0000562a88ddf060  bx: 00007f98dd3f08a0
  dx: 0000000000000006  ax: 0000000000000000  cx: 00007f98d2e6b428  sp: 00007ffd973d28e8
  ip: 00007f98d2e6b428 efl: 0000000000000202 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.
[34595:34595:0100/] Invalid node channel message

Interestingly, my machine has no problem with rstudio-server 1.2.792, but cannot start rstudio-desktop.

Also my Linux Mint runs on Cinnamon and I wonder if a different desktop environment would make any difference.