RStudio Notebook preview and output file do not show code output

My question is similar to this one. I am using the default notebook of RStudio (the one you get when you click "New file -> R notebook". When I run the code chunk


RStudio displays the result in the editor. However, when I click on "preview" the output does not show the result. The result is visible if I use the command "Knit to Html", but with less functionality so this is not what I want.

Rstudio Notebook did work fine for a few hours and then not anymore, I cannot find why.

I'm using the preview release of RStudio v1.1.430 (but had the same problem with the current non-preview version) and I am running R 3.4.3.

Could anyone help me?

Have you run the code chunks manually before clicking on "preview"?

Yes I did, this is what I meant by "RStudio displays the result in the editor".

Btw I saw your post similar to mine. It seems that you solved it using the "Knit to html" function. This function does work for me, but I want to get the "notebook preview" function to work.

I'm still running into this problem. Wonder if other people still are.