Rstudio help link is broken on rstudio installed on Ubuntu server

I have hosted rstudio IDE on an Ubuntu server on AWS to give a consistent environment to my R users. The Rstudio works fine but when you search a string for help the routing breaks as it tries to look for the help doc in the local machine as you can see browser goes to the following address,

Where is the config file for changing the help documentation url?


Which help link do you mean? There's the Help that will open the help viewer pane, in which you can search for certain results, but I'm not sure if that's what you mean:

Ah no, I use the bottom right side window in which there is a search text box. See screenshot attached.

The help menu option at the top works fine but you cannot search a string in there, can you? For successfully using help we need string search functionality.
Strangely the search bar is successfully dropping down all possible functions as you type the first few characters but as soon as I select one full string and press enter the routing goes to

What happens if you use ? notation:
e.g. ?udpipe::phrases() (I think that's what's open in your example above)

? also takes me to the URL and it gives the same error (this site can't be reached) while the browser shows the following address:

i am going nuts over this error which looks a simple redirection configuration.

Were you able to find out what the problem is?
Waiting for a solution.

I don't know what the problem is. And I'm sorry that you're still having trouble. :slightly_frowning_face:

It's possible the issues you're having are related, so please see my response and questions in your thread below:



I have no idea whatsoever whether this might help as I don't know how RStudio works. But since you seem at a loss, I thought that I would throw an idea out there, in case...

You could try to set options(help_type="text") in your .Rprofile and see what happens... Instead of outputting an html to RStudio (in ways that I totally ignore), it might output the help in less in your console... (that's what happens outside RStudio) and that might be a fix. Or a temporary fix until someone who knows the real answer to your problem can help you. I have never tried to set the help to text in RStudio though, so it might simply not work at all and be a useless idea... (outside RStudio, html help files usually open in your default browser and text files open in the console using less). Or you might run into the same problem of RStudio looking for a local file rather than a file on the server...

1 Like