Finding out my rstudio server version on my ubuntu

This is unbelievable.
I searched a lot but could not find this out.
The closest I got to the answer was people saying go to HELP and then ABOUT RSTUDIO and check the version.
My gosh-dern'it problem is, where is the ABOUT RSTUDIO option?
See my screenshot of the help menu,

I'm not on the IDE team, so please bear in mind that I'm troubleshooting this as a fellow user (and not a terribly advanced one, when it comes to RStudio Server).

  1. My first question is, are you using RStudio Server Pro? I believe Kevin asked the same of you in your IO error thread, but you haven't answered yet.

    I'm not having the same error on RStudio Server Pro (RSP), but perhaps it's something that's somehow happening in the OS build and not the Pro build for some reason, and knowing can help us narrow it down.

  2. Did you install RStudio Server yourself? If so, a possible (albeit incredibly low-tech/janky) solution would be to ~reverse engineer what the version might be through looking at the download links. For example, I often do a sort of quick visual check for Mac daily builds for 1.1.* versions just by looking at the page:

    The equivalents for RStudio Server on Ubuntu would be here for dailies of 1.1.*, or here for 1.2.* bleeding edge versions.

  3. What do you get if you run RStudio.Version()? For example, I get the following when I run that on my desktop version:

     #> $mode
     #> [1] "desktop"
     #> $version
     #> [1] ‘1.1.443’

    I realise the aim is to find the button itself, but knowing your exact version might help someone else to replicate the issue you're having.



Hi Sanjmeh,

One other thing that might help find the version - you can try running the command rstudio-server version on the command line, or even from the Terminal/Shell in RStudio and that should output the installed version information as well.



The above function doesn't exist @mara

Let me articulate the real problem.

As you would have guessed, just knowing the version isn't my real problem. Why I want to know the version is to check if my upgrade went through or not. And, why I want to upgrade, is because I am getting a plethora or errors on rstudio on the ubuntu server (to be clear it is non-pro rstudio) like a lot of packages not getting installed, the help not working, startup errors like these

Error in tools:::httpdPort > 0 :
comparison (6) is possible only for atomic and list types

and whenever I search for the solution the only advice I get is, upgrade your Rstudio, or upgrade your Rstudio or downgrade R version*.

@mara I request you to take a look at this SO answer as this answer may give some clues as to what is causing all this problem.

I upgraded rstudio painstakingly using this post but am not sure it has really upgraded because I still see the same problems. Perhaps there is another way to check if the upgrade went through.

Just for completion, I got following advice to check R version from an Rstudio employee here but it doesn't work either.

Ok, that might actually be a hint, since it does exist in more recent versions.

Since I've never installed RStudio Server on an Ubuntu machine, you've reached the limits of my knowledge, but hopefully someone else will know more.

Ian mentioned the rstudio-server and rstudio-server-version commands should be run from your shell.

It would give a result something like this:

username@servername:~/projects/myRproj$ rstudio-server
$Usage: rstudio-server {status|start|stop|restart|test-config|verify-installation|

username@servername:~/projects/myRproj$ rstudio-server version
1.1.442 (Professional)

You mentioned that you're just getting some AWS instances up and running for a classroom, is that right?
Can you reset it and start anew?

You might also want to make sure you're installing the server version and not the desktop version, especially if the rstudio-server commands aren't working. The instructions you linked from StackOverflow are for the desktop version - if you want RStudio Server, you'll want to make sure you're installing the latest server version following the directions here:


Ok, so finally I am able to fetch the rstudio version through the shell command:

rstudio-server version

It is 0.97.336

Now coming to your advice to upgrade rstudio server @EconomiCurtis, the below link you sent is for a fresh instal. Is there a separate link for upgrading. I am afraid I did do a fresh instal but cant see the upgraded version and also none of the bugs go away. So definitely, the fresh instal is lying in some directory on the Ubuntu server and the rstudio that I get at x.x.x.x:8787 is the old one.

Any tips?

Googling around RStudio IDE's knowledge base, the article on Upgrading RStudio Server has the following guidance;

Upgrading to a later version of RStudio Server

If you are upgrading to a later version of RStudio Server Open-source or Pro, you can do so by downloading the newer package and installing it using your package manager:

sudo gdebi <rstudio-server-package.deb>
sudo yum install --nogpgcheck <rstudio-server-package.rpm>

Your configuration and settings will be unchanged from the previous version, and if you are running RStudio Server Pro, your license status will remain untouched as well.

Here's info on where to get the newer package; Download RStudio Server >> Download and Install

Thanks @EconomiCurtis; I'll go for it. Let's see how it goes.