RStudio Desktop unresponsive in project

I'm running RStudio on a Windows 10 machine, and over the past month or so RStudio is completely unresponsive when I try to work inside a project. I can open RStudio and then I can open the project, but once the project is open, I can't even execute a single command in the console, it just hangs. Nor can I open anything through the file menus, or even successfully quit the program naturally. I will note that the projects I'm working in are all git-enabled directories, but I had successfully worked in this way for years before this issue started, and I am able to work with all of these project folders on another computer. I tried updating both RStudio and R, and then did a full uninstall/reinstall of RStudio, but neither had any effect. I'm currently running RStudio version 1.1.423 with R version 3.4.3.


I think sometimes the .Rproj.user folder can become corrupted and create this sort of problem. Have you tried copying the project to a new folder and removing .Rproj.user?


I did try deleting the .Rproj.user folder and there was no change. I will try moving the whole project to a new folder and report back, thanks.

Moving the project to a new folder did the trick! Thanks for the help. But I have this problem with multiple projects, not just one. Is there any sense of what causes this problem so that I can avoid it going forward? Or will I just have to move my files around to different folders every time this comes up? That seems like a cumbersome solution over the long term.

1 Like

Are you using git with these projects? We recently discovered an issue where, if the .git folder in the project directory became un-hidden for some reason, RStudio would hang on startup -- essentially, the console would not respond after attempting to submit commands to be executed.

Any chance that could be the case here?


The reason I suggested copying to a new folder was just so that you wouldn't lose anything if you chose to delete .Rproj.user! I don't know why it helped ... Agree it's not a very convenient solution in general.

That could definitely be the case here, I am using git with these projects.