RStudio Desktop fails to start after updating to v.1.2.1335 on windows 7

Error Information:

On startup, I'm receiving the following Windows error message: "RStudio has stopped working".

Description of issue -
RStudio Desktop cannot start after updating to v1.2.1335 on Windows 7.

Attempted steps taken to fix -

  1. Uninstalled RStudio entirely and reinstalled from

  2. Updated to R v.3.6.1, the most recent version.

  3. Deleted the RStudio-Desktop folder to reset RStudio's state.

  4. Checked properties of the RStudio-Desktop folder to make sure it has read, write, and execute permissions.

  5. Disabled my anti-malware when running RStudio.

  6. Held Ctrl when running RStudio to open the 'Choose R installation' dialogue and made sure RStudio was finding and using the correct version of R.

  7. Searched for any instances of .RData, .RProfile, and .Renviron files with the intent of removing them; however, I could not find any, as they cannot be seen from my home dir and I'm not sure what my most recent working dir was.

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 1.2.1335
  • OS Version: Windows 7
  • R Version: 3.6.1
  • Output your diagnostics report (if possible):
    I could not generate a diagnostics report. In run, typing the command 'C:\Program Files\RStudio\bin\Run Diagnostics.lnk' yielded the following error: 'Windows cannot find 'C:Program'. Make sure you typed the name correctly, and then try again.'. This was strange because typing 'C:\Program files\RStudio\bin' in run did open the correct directory.

From RStudio Desktop Will Not Start on

You need to quote the path here; e.g.

"C:\Program Files\RStudio\bin\Run Diagnostics.lnk"

I've had the exact same problem today. I found the diagnostic report, but apparently I can't add it yet as I am a new user.

Hi @Glenise!

You can copy and paste the contents of the report here (it’s just plain text), but please remember to select what you pasted and click the little </> button at the top of the posting box to make sure it doesn't get garbled by the forum software.

If you wind up with output that is too long to paste in here, please share it somewhere else (Google Drive, GitHub gist, Dropbox, etc) and link to it here.

Thank you! It was a big file, so I'll link it here:

Strangely, the RStudio diagnostics log does not contain any crash-related information.

If that still doesn't work, the only other guess I have is that this could be related to some other software installed and running on the machine that is somehow interfering with RStudio's normal processing. Some examples we've seen before:

It could be worth investigating whether closing some of the other software on your machine makes a difference.

Thanks so much for the response! Not sure if I had the same problem as Julian, but I will shut some other things down and give a try. I had no issues downloading and running it on my mac last night.

I have tried generating a diagnostic report again, this time typing the path within quotation marks as per your instructions. This yielded a different error, namely, "Windows cannot find 'C:\ Files\RStudio\bin\Run Diagnostics.lnk'. Make sure you typed the name correctly, and then try again."

It appears there is no Run Diagnostics.lnk within my \bin directory (checking via windows explorer confirmed this). There is however, an application called "diagnostics"; running this causes the shell to quickly open and close, and I cannot discern if it is producing any output files at all. Any further ideas for getting that diagnostics report?

To be clear, no rstudio-diagnostics directory is being generated in my Documents folder after any of these attempts.

Reinstalling RStudio Desktop, now v.1.2.5001, has resulted in the proper installation of Run Diagnostics.lnk, which I have now successfully run. Please find the output below:

[1] "1.2.5001"

[1] "C:\\PROGRA~1\\R\\R-36~1.1\\bin\\x64\\R.exe"

[1] "C:\\PROGRA~1\\MIKTEX~1.9\\miktex\\bin\\x64\\pdflatex.exe"

[1] "C:\\PROGRA~1\\MIKTEX~1.9\\miktex\\bin\\x64\\bibtex.exe"

[1] ""

[1] ""

[1] ""

R version 3.6.1 (2019-07-05)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 7 x64 (build 7601) Service Pack 1

Matrix products: default

[1] LC_COLLATE=English_Canada.1252  LC_CTYPE=English_Canada.1252   
[3] LC_MONETARY=English_Canada.1252 LC_NUMERIC=C                   
[5] LC_TIME=English_Canada.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_3.6.1 tools_3.6.1   

                     sysname                      release 
                   "Windows"                      "7 x64" 
                     version                     nodename 
"build 7601, Service Pack 1"             "JULIANMORAN-PC" 
                     machine                        login 
                    "x86-64"               "Julian Moran" 
                        user               effective_user 
              "Julian Moran"               "Julian Moran" 

R Version:
platform       x86_64-w64-mingw32          
arch           x86_64                      
os             mingw32                     
system         x86_64, mingw32             
major          3                           
minor          6.1                         
year           2019                        
month          07                          
day            05                          
svn rev        76782                       
language       R                           
version.string R version 3.6.1 (2019-07-05)
nickname       Action of the Toes          
[1] "C:\\ProgramData"

[1] "C:\\Users\\Julian Moran\\AppData\\Roaming"

[1] "Destination=file"

[1] "1"

[1] "C:\\Program Files\\Common Files"

[1] "C:\\Program Files (x86)\\Common Files"

[1] "C:\\Program Files\\Common Files"


[1] "C:\\windows\\system32\\cmd.exe"

[1] "NO"

[1] "-1"

[1] "-1"

[1] "C:/Users/Julian Moran/Documents"

[1] "C:"

[1] "\\Users\\Julian Moran"

[1] "C:\\Users\\Julian Moran\\AppData\\Local"


[1] "C:\\ProgramData\\Microsoft\\Windows Defender"

[1] "AntiSpyware"

[1] "C:\\Program Files\\Windows Defender"

[1] "C:\\Users\\Julian Moran\\AppData\\Local\\Microsoft\\Windows Defender"

[1] "E34373DA-32E4-4FC5-AA69-71F64DFEF1CF"

[1] "R_ARCH"

[1] "2"

[1] "C:\\Users\\Julian Moran\\OneDrive"

[1] "C:\\Users\\Julian Moran\\OneDrive"

[1] "Windows_NT"

[1] "C:\\Program Files\\R\\R-3.6.1\\bin\\x64;C:\\Program Files\\Common Files\\Microsoft Shared\\Windows Live;C:\\Program Files (x86)\\Common Files\\Microsoft Shared\\Windows Live;C:\\windows\\system32;C:\\windows;C:\\windows\\System32\\Wbem;C:\\windows\\System32\\WindowsPowerShell\\v1.0\\;C:\\Program Files (x86)\\Windows Live\\Shared;C:\\Program Files\\MiKTeX 2.9\\miktex\\bin\\x64\\;C:\\Program Files (x86)\\Skype\\Phone\\"


[1] "AMD64"

[1] "Intel64 Family 6 Model 23 Stepping 10, GenuineIntel"

[1] "6"

[1] "170a"

[1] "C:\\ProgramData"

[1] "C:\\Program Files"

[1] "C:\\Program Files (x86)"

[1] "C:\\Program Files"

[1] "$P$G"

[1] "C:\\windows\\system32\\WindowsPowerShell\\v1.0\\Modules\\"

[1] "C:\\Users\\Public"

[1] "1"

[1] "/x64"

[1] "gcc 4.9.3"

[1] "C:/PROGRA~1/R/R-36~1.1/doc"

[1] "C:/PROGRA~1/R/R-36~1.1"

[1] "C:/Users/Julian Moran/Documents/R/win-library/3.6"

[1] "C:/Users/Julian Moran/Documents"

[1] "C:/Program Files/RStudio/resources/mathjax-26"

[1] "\\\\.\\pipe\\47995-rsession"

[1] "C:/Program Files/RStudio/bin/rpostback"

[1] "63341846741"

[1] "1"

[1] "256"

[1] "80"

[1] "C:/Program Files/RStudio/bin/msys-ssh-1000-18"

[1] "C:/Program Files/RStudio/bin/pandoc"

[1] "47995"

[1] "Julian Moran"

[1] "C:/Program Files/RStudio/bin/winutils"

[1] "Console"

[1] "C:"

[1] "C:\\windows"

[1] "C:\\Users\\JULIAN~1\\AppData\\Local\\Temp"

[1] "xterm-256color"

[1] "C:\\Users\\JULIAN~1\\AppData\\Local\\Temp"

[1] "JulianMoran-PC"

[1] "Julian Moran"

[1] "C:\\Users\\Julian Moran"

[1] "C:\\windows"


 [1] ".GlobalEnv"        "tools:rstudio"     "package:stats"    
 [4] "package:graphics"  "package:grDevices" "package:utils"    
 [7] "package:datasets"  "package:methods"   "Autoloads"        
[10] "package:base"     
Log file: rdesktop.log


Log file: rsession-Julian Moran.log


Unfortunately, nothing stands out from the diagnostics report. :-/

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.