RStudio blank screen

Error Information:

R runs without a hitch in my computer. However, when I try to run RStudio, all I get is the menu, and a blank screen below it -

Attempted steps taken to fix -

I have started RStudio pressing CTR to change the rendering method, to no effect

System Information:

  • RStudio Edition: (Desktop or Server) Desktop
  • RStudio Version: Free
  • OS Version: Windows 10
  • R Version: 4.1.1
  • Output your diagnostics report (if possible):

From RStudio Desktop Will Not Start on

If RStudio is a new installation, I'd purge it and re-install.

Also, since it is Windows, a hard reboot.

Thanks. I tried. Didnt make a difference. This is all I get:

I have no idea and I know nothing about Windows .

Sorry to be of so little help.

No, no, no need to be sorry at all. Thank you for paying attention. I was venting, for the most part. I am bit suprised that no one on the RStudio development team seems to be paying any attention to this. I have read multiple posts of people with the same problem, and have not yet found a single useful answer

Have you tried resetting RStudio's state?

The same here.

System: openSuSE 15.3 and OpenSuSE Tumbleweed an a Dell XPS9500, Nvidia graphics card disabled.
Rstudio: latest version
R version: 4.1.1

Steps taken: Reinstalled R-studio, resetted Rstudio according to the support articles, set rendering to software in the ini, did a diagnostics run, nothing unusual, Rstudio is able to connect to R.

Interestingly, rstudio starts when running as root user.

similar problems reported by my here: Rstudio does not start in Ubuntu 21.10
But I have that same problem only under OpenSUSE Tumbleweed, not Leap15.3.
See the --no-sandbox partial workaround in that thread for a temporary half solution.

Works. Cool, thanks !

Will try this. Thanks

Complete work around with an environment variable RSTUDIO_CHROMIUM_ARGUMENTS, see same ref as before: Rstudio does not start in Ubuntu 21.10

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.