Rstudio does not start in Ubuntu 21.10

I've updated to Ubuntu 21.10 and now Rstudio does not start any more. I've tried the last version of Rstudio, 1.4.1717. It just produces a grey screen. I could not get any other information, for instance starting it from the command line I don't get any error message.

The menubar is seen but clicking on it does nothing. To close Rstudio (the grey screen) the process has to be killed.

1 Like

I have very similar issues under OpenSUSE Tumbleweed, KDE with newest patches applied. I have tried several versions of RStudio Desktop IDE. The current 2021.09. Some Dailies. (Since a long time I am running dailies, so far all okay, not any more) I know the rolling release Tumbleweed is not on the list of supported Linux OS. But that was up to now never an issue, I just install the OpenSUSE 15 rpms on Tumbleweed. Compatible.

On the same system RStudio Server (dailies as well) is installed too. This is still fine. On localhost:8787 I can open any Rproj just fine, all works as expected.

I went through all the recommended repair steps. The only one I did not attempt so far is a full R reinstall. It would be a huge effort to reinstall the big load of packages already here. And as the RStudio server has no problems at all with that same R setup, why should the desktop IDE?

gdb /usr/lib/rstudio/bin/rstudio from a terminal session as a normal user does not give useful debug information. No logfiles anywhere when started from a terminal session window.

From a root Terminal session /usr/lib/rstudio/bin/rstudio works as expected.
So probably there is a access rights problem interfering when not run as root. I could verify that, another normal user can not run rstrudio as well. Same white window with menu bar only.

How could I pinpoint the problem behind the scene?

Same here from a Kubuntu 21.10 and last build of Rstudio community edition.
The app is launched and loads the menu bar... and nothing more. It requires an explicit kill to close everything.
It's pretty frustrating because I didn't found any clue either. No crash message. Didn't find any log. Running from terminal doesn't show any output either.
I was quite surprised by @gsgmx info, that it worked with roots privileges. I tried. It does indeed. Weird. Nevertheless it's not something I'd like to do.
From other apps I'm running and that recently and suddenly crashed, I got a hint and found something that might help, while waiting for a more professional answer from someone...

From the terminal and as regular user, run:

rstudio --no-sandbox`

You won't find this possibility anywhere : there's no --help option or man page. But it's working for me.

I suspect this relates to these guys discussion, but I'm not sure.

Happy to do some testing too if someone skilled enough is able to pinpoint us to some procedure that might reveal what's crashing here.

@mcar176 I can confirm,
rstudio --no-sandbox
does the job for normal users. A good workaround for the moment.
And certainly no, I would not attempt to run RStudio as root in normal day to day usage. I did that just to find out, whether it makes a difference under the current circumstances.
Your link to the ubuntu / glibc issue with electron based apps might point into the right direction. As far as I looked at the dailies change logs, there seems to be electron 14 in use now. Not sure though.

You use Kubuntu, so probably the KDE/Plasma environment, I use OpenSUSE TW with KDE/Plasma. So if @wagafo uses KDE as well it might point to a KDE issue, if not we have to look elsewhere.
Another application which fails since the last big OS upgrade is Firefox ESR. Currently at version 78.14.0esr.

Gah. Your tab just crashed.
We can help!

Choose Restore This Tab to reload the page.

Any tab will crash. 100% deterministic.
Actual Firefox, (not ESR) version 92.0 runs without such problems on the same system.

even after updating today to the newest versions of the OS (Tumbleweed 20211005 rolling release) and newest RStudio daily release (2021-12 108) the problems remain the same.
Need --no-sandbox for RStudio and Firefox ESR 78 can not display any tab.
I have still no idea how to debug. According to my former experience with these problems but no further information it is a waste of time and effort to file a bug report for SUSE or KDE or RStudio.

Hopefully somebody will be able to pin down the specific problem.

Update - still an issue.
Today, after updating both the OS and its current libs fully and updating RStudio to
RStudio 2021.12.0-daily+120 "Prairie Trillium" Daily (ef2c7e6052c625faea3f62d2ff37cdc7d85c3074, 2021-10-11) for OpenSUSE 15 Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) QtWebEngine/5.12.8 Chrome/69.0.3497.128 Safari/537.36
the problem remains the same. It can only be started with the --no-sandboxparameter. Sad.

Seems I am on my own for this now. Should I open a ticket at the RStudio GitHub repo anyhow?

Edit/Add, 1 day later:

Did a crosscheck with a current, newest update and newest kernel OpenSUSE Leap 15.3 (which is nowdays nearly 100% the same as SLES 15.3) .
It comes with glibc 2.31. No issues there. So I can not open a ticket for the issues I have under OpenSUSE Tumbleweed (glibc 2.34) anywhere.
In the future the issue might have to be addressed by either RStudio or SUSE if it creeps up in the 15.x release.
I have no idea how to really solve the problem now.

Edit/Add another day later:
Next Update,
today the OS updater brought a new glibc subversion,
rpm -q glibc
from The GNU C Library

  • The current stable version of glibc is 2.34, released on August 1st, 2021.
  • The current development version of glibc is 2.35, releasing on or around February 1st, 2022.

no progress at all. If this glibc 2.34.x really is the cause as @mcar176 assumes, and nothing happens in between, we might have to wait for a fix until sometime February 2022 at least.
Good opportunity for me to forget RStudio for a while and finally learn Python (PyTorch) now?

At least in Ubuntu a glibc fix is implemented now. See the mentioned above thread, especially Comment #36 : Bug #1944468 : Bugs : glibc package : Ubuntu

I'm sorry you didn't find any fix. Unfortunately I'm not skilled enough to help you. For what it's worth:

  • I can confirm some fix appeared at some point through ubuntu repo, and rstudio's launch doesn't freeze any longer (if libc is the culprit, i'm now with the 2.34-0ubuntu3version... )
  • I think your idea of submitting the issue on GitHub is the right one. This might be a better place to get sighted by developers... I've got the feeling this community forum won't help...
  • In any case, from what I experienced --no-sandbox doesn't seem to alter functionalities, even though it doesn't solve the issue.
  • There are many other options but they all seem quite more painful than the latter. Dockerized RStudio or in a local virtual environment, VScode as an IDE for R, jupyterlab/notebook with R... Learning Python can be fun too but this looks like another road and an independent decision.

Best of luck. (happy to help more if you need. just cite my pseudo because i don't check the forum)


  • good you can confirm that the problem is already solved under the newest Ubuntu version. Yes the 2.34-0ubuntu3 version is the one mentioned as solving the electron 14 glibc timeout or so.
  • --no-sandbox is automatically set when RStudio is started as root on Linux:
    from: rstudio/src/cpp/desktop/DesktopMain.cpp
#if defined(Q_OS_LINUX) 

      static char noSandbox[] = "--no-sandbox";

      // is this root? if so, we need --no-sandbox on Linux.
      // see
      if (core::system::effectiveUserIsRoot())


so this explains why starting RStudio as root does not show the stuck at white screen problem.

  • yes --no-sandbox is a reasonable work around. For one project/session opened. Starting from that further sessions will fail with the known symptoms.
  • From my point of view for a solution we would need an glibc update for OpenSUSE. I should file an issue. From earlier experience they accept only well elaborated problem reports which I fear I am not able to provide at this stage.

@gsgmx thank you for the update and your explanation. Great finding ! This clarifies a behavior that I wasn't understanding (successful launch as root) and documents an official use of the --no-sandbox option with rstudio.
Maybe some elaborated reports will come from other concerned apps that provide more verbose outputs than rstudio as they fail to launch. This seems to be a concern for many people/profiles/applications with not that much uncommon configs.

@mcar176 following the --no-sandboxtheme on rstudio github I found:

where the shell variable RSTUDIO_CHROMIUM_ARGUMENTSis suggested for setting --no-sandbox.
Did that, works for me! So we have now a complete work around. Further sessions can be started from a running RStudio session now too.
Now I wait relaxed for a repaired glibc.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.