Rstudio 1.3 + Rtools40 Crashes Whole System when Creating New Project


I have been experiencing issues where I can't create a new project with the latest version of Rstudio, and Rtools40, with R version 4.0.1 on Windows 10. When I tried doing this, my computer becomes super slow that restarting it is the most reasonable solution to recover my computer's state. I tried following several troubleshooting guides, including reinstalling Rstudio, making sure that Path has been defined accurately for Rtools 40, but none of them solved the issue.

However, when I turned off the R diagnostic and switched back to R version 3.6.2, the new project dialog started seamlessly after I tried to create the new project. My laypeople perspective to this is that the problem is associated with Rtools40, but I am happy to learn more insights from more experienced community members.

In my case, I would just create a new project with R version 3.6.2 before running my analyses with R version 4.0.1.

Okay, here's my take on this...

Very few people actually need R Tools. So, if you don't need it, I strongly recommend against installing it.

You only need it if you are using packages or writing packages which require compilation, that is those which include underlying C/C++/FORTRAN code.

You will, on occasion, when installing packages be prompted with:

There are binary versions available but the source versions are later

Followed by a list of packages and version numbers, then the question,

Do you want to install from sources the package which needs compilation?

It is natural to want to say yes to this, afterall you want the latest and greatest package available with all the new features and fixes! However, I would advise against this predominately because this will often require users to have R Tools installed on Windows or a recent version of XCode installed on OSX. So, in short, "just say no!"

Most users of R will never need this. If you do, that's fine, I and others will be happy to help you work through whatever issue is stopping you from proceding. But, if you don't really need to be able to compile sources we can simplify the process and expidite you on your way to productivity.

So, if you are willing to humor me, what I would suggest is this,

  1. Uninstall all versions of R, R Tools, and R Studio from your computer.
  2. Install R 4.0.2 from here: Download R-4.3.3 for Windows. The R-project for statistical computing.
  3. Install R Studio 1.3.1073 from here:
    3.5. A reboot of your computer at this point wouldn't be a terrible idea.
  4. Open R Studio and make sure it loads correctly, specifically that it shows the orrect and current R Version in the console pane.
  5. Attempt to create a basic project.
  6. Report the results back to us here.

If this works great, we have narrowed things down. If it doesn't work, I suggest trying this here:

Which is my go-to suggestion now anytime something "wonky" is happening in R Stduio.
If it still doesn't work, some areas which I have seen cause issues include:

  • Are you installing R and R Studio in their natural, default locations or are you choosing different places for them?
  • What is the permission set of the user account you are using when launching R Studio? If you choose to "Run as Administrator" does the issue persist.
  • Does the username of the account you are using have any non-ascii characters in it or does it have any spaces in it? I teach R at a university and occasionaly see international students run into issues when they have spaces or double-length unicode characters in their system account username.
  • Do you have any anti-virus, anti-malware, or firewall software running? I have seen it happen where over aggressive safety features prevent the installation or execution of programming tools on Windows. A very small proportion of Windows users have need of tools whcih can create executable code, so by default, any software capable of creating executable files is treated with heightened suspicion. If you are attempting to create an R Project (especially with R Tools installed), your protective softwhere may be running interferance without reporting any error code to R Studio, so R Studio could be hanging waiting for a response. You could attempt to disable all protective measures on your PC and try again. (Disconnect from the network first if you have security concerns, then re-enable everything after your test.) If this works when other things have failed, you'll want to figure out how to whitelist R, R Studio, and R Tools on your particular setup.

If none of that works I would be very surprised and my guess would be you have some other software on your system which is causing a conflict. One which springs to mind would be to ask, "how are you installing R, R Studio, and R Tools?" I recently became aware of the Windows package manager Chocolatey when it was deduced as being responsible for another user's woes. So, I would encourage you at this point, if nothing thus far has remedied the problem, to think long and hard about any other peculiar aspects of your setup no matter how trivial or inconsequential or ridiculous is seems it would be for them to be the cause of your troubles.

Otherwise, it seems you've found an interim solution at least, which is good.

Good luck!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.