RPubs error: 'slug is already taken'


I would like to share a personal update about a previously-reported error that arises rarely when republishing to RPubs. When there's an error while an RPubs document is being republished, the RPubs URL corresponding to that document can go into a broken state.

The error can be reproduced by publishing any document to RPubs, republishing it, and stopping the republish process while it is in progress (such a situation can happen if a user decides to make a change after pressing the 'Republish' button).

In an issue about the same error from some months ago, @jcheng responded:

Since I have run into the same error with one of my publications, I would be sincerely grateful for any advice from Joe or someone else regarding how to liberate the URL from the broken state.

Thank you very much

You should be all set now. Sorry for the inconvenience.


Thank you very much!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.