ODBC connections started producing an error after an R Studio update

It looks like I have a conflict between 64 bit R Studio and 32 bit MS Access. This problem arose after an update, and it looks like that update included removing 32 bit R Support from the platform. It also looks like they re-introduced the 32 bit support in a patch, but I believe I have that patch and I still seem to have the conflict, and cannot resolve it.

After returning from a short vacation, I discovered an R Studio software update took place at work. As of right now, I am using R Studio V1.2.1335.

After the update, a report I have been working on no longer connects to the local MS Access database I was using, and I am at a loss as to how to re-establish the connection.

con <- dbConnect(odbc::odbc(),
                 driver = "Microsoft Access Driver (*.mdb)",
                 Dbq = " C:/Users/myname/Documents/R/myDataBase.mdb ",
                 Uid = "Admin" ,
                 Pwd = ""

I use a 32 bit MS Access, 64 bit R studio. This is not optional, it's office software, so I can't use different versions of either.

Previously the connection was established and data was importable. Currently I get the following error:
"Error: nanodbc/nanodbc.cpp:950: IM002: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified"

Attempted Remediation

Stack Overflow thread was not successful.

I have verified that I have 32 - bit Access drivers installed using the 32 - bit ODBC connection manager. The connection worked before, so this was expected.

I have seen some help threads that indicate that this was a 32 bit support issue for R-Studio which was removed around October of last year, then re-introduced in patch 1.2, which I believe I have installed based on the version number of my R Studio IDE.

I currently have 32 bit R installed. I cannot switch my R Studio to 32 bit "mode", and I have tried to manually point my R Studio to the 32 bit executable using the Global Options, but it remains unavailable for selection.

This thread seems to indicate that the connection was nixed by the update, and the R Studio Employee in the thread indicates that he doesn't see a specific need to run 32bit R at all. This makes me suspect the necessity of the 32bit option in the Global Options. His response sort of indicates I can connect to the 32 bit Access using 64 bit R Studio, because I really cannot imagine that "I need to connect to 32 bit MS Office software" was a valid answer to that. I am still learning my way around the software. I know I am dropping the ball somewhere, I just cannot for the life of me find where.


Can someone confirm that this is, in fact, an ELF conflict motivated by an R Studio update feature? Is there a workaround or update that will allow my 64 bit R Studio to connect to my 32 bit MS Access? Can anyone offer some clarity as to the intended functionality of the R Studio IDE after patch 1.2 versus what I am seeing with a lack of 32 bit selectability; is this functioning as designed?

Thank you for all your help.

I believe the preview version of RStudio (v1.2.1555-4) fixes this problem. See: https://www.rstudio.com/products/rstudio/download/preview-release-notes/ for the release notes, and https://www.rstudio.com/products/rstudio/download/preview/ to downlad.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.