Installed but the library is't working

the tidyverse package is installed on my R studio (R version 3.6.1 (2019-07-05) using Mac Catalina. but I can not run the tidyverse library. and always says "Error: package or namespace load failed for ‘tidyverse’:
object ‘is_present’ is not exported by 'namespace:lifecycle"
I have tried to find the solution in internet, and I can see that there was similar problem raised in this community (cannot load tidyverse) but do not see if it was solved.

Anyone who has solution is much appreciated.
Thanks in advance.

This would seem to be in question,...
When you run install.packages('tidyverse') does the log execute cleanly, and give you an ok ?

package ‘tidyverse’ successfully unpacked and MD5 sums checked

hi nirgrahamuk,
not really, but
either install.packages("tidyverse") or with install.packages("tidyverse", dependencies = TRUE) seems to download the package, but when I load the library it shows error.

here I attached the screenshot,


would be great if you could help me with this issue. thank you.

1 Like

seems odd, I'd expect an attempt at install after the download step.
Would you consider upgrading to an R version after 4.0 ?

Try reinstalling the lifecycle package

1 Like

nirgrahamuk: I would if it is the only solution, however I had a quick look that R version after 4.0 is for Mac Sierra and higher, My MacOS is Catalina Ver 10.15.6.

@andresrcs andresrcs: thanks, I try to do so, and now I have to deal with never-ending confirmation that always pop up, as I attached, is it ok to select cancel or no?!

Catalina is higher than Sierra though

@andresrcs, and nirgrahamuk: after instaling install.packages("lifecycle") now the library(tidyverse) can be loaded but not completely loaded all the packages, as I show in the screenshoot.

might be upgrading the R is the only solution?

They all appear loaded from your screenshot.the green ticks near the names and version numbers indicate that.

@nirgrahamuk: how about the packages below the Conflicts? there are two dplyr in red-cross signs.
x dplyr: filter (). and
x dplyr: lag()

those are function conflicts, not package conflicts. the packages load in a certain order, and can mask functions its letting you know that when you do filter() you will be getting dplyr::filter rather than stats::filter
(but you can always use the full function name if you want to access a masked function)

1 Like

@nirgrahamuk thank you very much for your help and explanation.

Best wishes,

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.