I am getting this error again and again of crash previous session.

It appears that you are using Posit Cloud (which updated to R 4.2.3 today). If so, you should add the Posit Cloud tag to the title.

You have given us very little information. What happens when you click on OK? Assuming this is Posit Cloud, have you tried Relaunch Project?

when I click on ok all the previous data or work has been lost.
What should i do now?

None of the data or your saved scripts appear under the Files tab? I have had to relaunch projects to get unfrozen, but never lost anything. Does the Google Data Analytics Certificate (I recognize the data for their capstone) have any technical support?

yes all the imported files has been lost. Is it due to data given by Google for capstone?

I do not know how the data files could possibly cause such a problem. Were you doing all the work in the Console or saving it in R Scripts?

I am afraid I do not have a solution. Hopefully someone else will have more experience recovering from this kind of crash. Good luck!!

I dont think so data files can cause such problem. I am doing in console. I dont know how to fix it.
Thanks for your response. I will wait for someone else to give response. Hopefully I will get the solution.

Hi, welcome to the forum.

We need a lot more information about what you are doing when this happens.

Have a look at this FAQ for some suggestions on the types of information we are likely to need. It also would help if we had the output from


Thanks for your response. Actually when I import data on console after installing libraries and packages, it happens every time after importing 5-6 csv files. I did quite the project and relaunched the project but got this error again.

We really need more info. What exactly are you doing (we need to see the code) when this happens? We need a something like a reprex or minimal working example of what is happening. Of course you won't be able to do a real reprex as you are crashing but all the code leading up to this should help.

At the moment we have no idea of what you are doing, what packages you may be using or even what version or R or RStudio you are using. The sessionInfo() output will tell us the last part.

Have you tried a complete reboot of the system?

here im attaching the sessionInfo() code to show what i am doing.

I imported 8 files on console this time then faced same error and all the files has been lost from environment.
I dont know where is the problem actually.

Thanks for the screenshot but it is better to provide formatted code.
You can simply paste it between these ` symbols as in the example below.

> dat1  <- data.frame(aa = c(1, 2, 3, 4, 5), bb = c("A", "B", "C", "D", "E"))
> str(dat1)
'data.frame':	5 obs. of  2 variables:
 $ aa: num  1 2 3 4 5
 $ bb: chr  "A" "B" "C" "D" ...

These marks will disappear in the message.


You appear to be running R 2.2.3 under Ubuntu 20.04.5 but I don't see any packages loaded other than the expected base packages. However you are using "read_csv" so I am wonduring why I am not seeing the {readr} listed under "other attached packages". Strange.

I am not familiar with Posit Cloud.
Let's take it one file at a time and see what is happening.

Can you load one .csv file, call it df1, and provide the output of


to give us some idea of idea of the type of data you are handling?
You may be hitting a memory problem. Perhaps someone with Posit Cloud experience could comment?

Here I imported one file with name df1 and here is the output.

But when I keep importing more files like 5-6 then it gives error of crash and all the files that imported has been lost.

Please include code and not junt screenshots.

Given the size of df1 my guess is that by loading 5 to 8 files you may be hitting a Posit Cloud memory problem but this is just a guess.

Why are you loading that many .csv files at one time? Do you need them all in a single analysis.

Forgot; what version of RStudio are you using?

Yes I need all these files for one analysis.
Its R 4.2.3

Here are the recent ones where i imported files which can be seen in environment but then all has been lost.

No that is the version of R. To get the RStudio version do
Help -> About R Studio - hit the copy button and paste the results here.

I cannot see anything in the Environment window only the list of .csv files.

How exactly are you loading each file? Are you using code like

df1  <- read_excel("myfile.csv"

or using the file window?

I just checked at the Posit site and found this Posit Cloud (formerly RStudio Cloud) Memory Usage Errors/Application Failing to Load

This tends to make me think my guess of a memory problem is likely correct.

The memory gauge in the third picture is orange, which means it is close to full. That is with just one file in the global environment. The free version of Posit Cloud has just one GB of RAM.