Error to shinyApp because of reticulate

I've been trying to deploy to shinyApp from RStudios but keep getting the following error:

Preparing to deploy application...DONE
Uploading bundle for application: 819978...Error:

  • reticulate is in use, but python was not specified
    Execution halted

I tried to correct this error by adding the following line of code and ran it before connecting to the shinyApp server, but still didn't work. If anyone has any ideas that'd be greatly appreciated!!

What version of rsconnect are you using?
What are your applications dependencies (rsconnect::appDependencies())?

A post was split to a new topic: deployment error

I had the same error and ran this command and it fixed it (it just downloads an older version of rsconnect). If this doesn't fix it, it would help to see more of your code where reticulate is relevant.

devtools::install_github("rstudio/rsconnect", ref='737cd48', force = TRUE)

Good luck!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.