Dependency error when installing RStudio on Ubuntu 22.04 with libssl.

I am trying to install RStudio on Ubuntu 22.04. I currently have R 4.1.2 installed on it.

I use the following command as superuser to install RStudio:

gdebi rstudio-2022.02.1-461-amd64.deb

When I try installing, I get this error message:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: libssl1.0.0|libssl1.0.2|libssl1.1

I currently have libssl3 installed (3.0.2-ubuntu1). I cannot find any candidates using apt-cache search libssl1.

I've looked up others' attempts on Stackoverflow here, but to no avail: Installing R Studio on Ubuntu 22.04 - Stack Overflow

How do I go about installing Rstudio on Ubuntu 22.04?


Exactly the same issue here I followed the instructions with the version suggested here and nothing. I also tried with anaconda-navigator doesn't even download it. Any help please.

I solved it by following this


We're working on preparing a version of RStudio that is compatible (out of the box) with Ubuntu 22; if you'd like to try it, you can get it here:


Thank you for this! <3


Thanks for the link. I can move this to a new thread, but I tried the most recent build on Ubuntu 22.04 with R 4.2.0 and the install works fine, but the app crashes every time:

 ~  rstudio                                                               ✔ │ 21:42:36
TTY detected. Printing informational message about logging configuration. Logging configuration loaded from '/etc/xdg/xdg-budgie-desktop:/etc/xdg/rstudio/logging.conf'. Logging to '/home/johncassil/.local/share/rstudio/log/rdesktop.log'.
[14554:14554:20220502,214239.632503:ERROR] read out of range
[14554:14554:20220502,214239.632573:ERROR] missing nul-terminator
[14554:14554:20220502,214239.633998:ERROR elf_dynamic_array_reader.h:61] tag not found
[14554:14554:20220502,214239.634127:ERROR] read out of range
[14554:14554:20220502,214239.634132:ERROR] read out of range
[14554:14554:20220502,214239.634140:ERROR] read out of range
[14554:14554:20220502,214239.634147:ERROR] read out of range
[14554:14554:20220502,214239.634162:ERROR] read out of range
[14554:14554:20220502,214239.634182:ERROR] read out of range
[14554:14554:20220502,214239.656260:ERROR] read out of range
[14554:14554:20220502,214239.656271:ERROR] read out of range
[14554:14554:20220502,214239.656289:ERROR] read out of range
[14554:14554:20220502,214239.656305:ERROR] read out of range
[14554:14554:20220502,214239.656343:ERROR] read out of range
[14554:14554:20220502,214239.656394:ERROR] read out of range
[14554:14555:20220502,214239.658461:ERROR] opendir: No such file or directory (2)
[1]    14548 segmentation fault (core dumped)  rstudio

I had the same problem with the SSL dependencies as the OP and on a fresh and updated install of Ubuntu Mate 22.04. The dailies worked perfectly, thanks for the link!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.