Citations not working at all in RStudio, latest version

@deer2014ba is not in that file it seems.

Do you have this box ticked ?


I believe unbracketed citation are in-text citation. Unclicking this in the visual editor insert citation menu will insert the bracket (at least it does for me with latest IDE version)

You should check the indentation YAML maybe. If still not working, then can you share the qmd file so that I can download and run avoiding copy-pasting

Also, execute does not take all possible options, only some common one for all type of computing engine See Quarto – HTML Options

To pass more knitr only options in YAML (like cache-lazy), this is another syntax