Citations not working at all in RStudio, latest version


I'm using version 2022.12.0+353 on macOS; I'm writing a Quarto document and would like to insert inline citations.

I've set up Zotero with its BetterBibTex plugin and checked the option in RStudio to use Better BibTeX citations. This seems to work fine, as I can easily add citation keys from within RStudio:

However when I render the .qmd file in either HTML or docx format, the citation keys are left as-is, and no bibliography is attached to the end of the document.

I don't know if this matters at all, but I noticed that when I insert a citation key using the GUI, the key is added without brackets. I've tried rendering citations either with or without surrounding brackets, but it didn't work.

I would be very grateful if anyone could help me debug this feature, as it is super important for my work.


Can you supply us with a MWE example of the document? Just the YAML and a few lines of text should do.

Someone here should be able to at least see if it will run with one of their bibliographies.

And, perhaps the results of sessionInfo(), thanks.

To be extremely frank, I don't understand what a reprex could ever be in this case, still:

title: "Relationship Between Common Psychometric Variables and Outcome of Spinal Cord Stimulation"
author: "Marco Baciarello, Simona D'Agnelli, […] and Elena Bignami"

# Doc style specifications
#    tbl-title: Tab.
#    subref-labels: none
tbl-labels: none
tbl-cap-location: bottom
editor: visual
        mainfont: SF Pro Display

        theme: journal
        fontsize: 12pt
        #cite-method: biblatex
        toc: true
        number-sections: true
        highlight-style: github
        #cite-method: biblatex

# Set common chunk options
    echo: false
    output: false
    autodep: true
    cache-lazy: false
    cache: false
    warning: false
    message: false
    error: false
    freeze: auto

bibliography: references2.bib

Body of text:

Guidelines on the appropriateness of neuromodulation by the INS “recommend” a psychological evaluation to confirm a patient’s indication to trial [@deer2014ba].

Again, please note that when I use the GUI to insert the citation, RStudio omits brackets around the citation (i.e., @deer2014ba in this case). Also note that the unbracketed citation appears in a different color in the source code, but is rendered as-is in normal text in the HTML.

The references2.bib file can be found here (GDrive download), if it's any help.

I don't think this has anything to do with the matter at hand, but the YAML execute command isn't doing anything for me, I'm still getting all code echoed in the HTML.



@deer2014ba is not in that file it seems.

Do you have this box ticked ?


I believe unbracketed citation are in-text citation. Unclicking this in the visual editor insert citation menu will insert the bracket (at least it does for me with latest IDE version)

You should check the indentation YAML maybe. If still not working, then can you share the qmd file so that I can download and run avoiding copy-pasting

Also, execute does not take all possible options, only some common one for all type of computing engine See Quarto – HTML Options

To pass more knitr only options in YAML (like cache-lazy), this is another syntax

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.