Can't install Rstudio on Debian 9

I'm trying to install rstudio (rstudio-1.2.1335-amd64 ) in my debian 9 system, but I always have the error message : rstudio depends of libclang-dev .
Can you help me?

This means you need to install libclang-dev on your system (as opposed to it being an R package, or something of the like). I know very little about Debian, but see here for the package itself:

Thanks mara ; I tried ti install libclang-dev but I had the error that libclang-dev can't be installed

Hmm, I'm not sure what a good next step is, but the error message will definitely be helpful for someone who does! :slightly_smiling_face:

Unfortunately this libclang-dev error is tricky. You can try some of the ideas in this similar thread where we tried to debug the same issue on Ubuntu 19.04 (thus far unsuccessfully).

@ezio Have you ever installed RStudio on this machine before? Could you see if you can install RStudio 1.1 or other previous versions?


More resources:

  • Community thread with RStudio Engineers helping with the troubleshooting
  • GitHub Issue about the difficulty of installing libclang-dev

Thanks so much @jdblischak!!!
Rstudio 1.1.463 is installed correctly
I hope that developers can correct the bugs of new versions of rstudio on Debian

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.