Cannot select text in Rstudio desktop

This morning when I started up Rstudio (after having used it for years) it showed only a black screen. This did not resolve upon restart so I uninstalled Rstudio then reinstalled.

With the reinstallation I see a somewhat normal screen, but am unable to select text in the scripting window. The cursor is there but it scans over the text.

I reinstalled Rstudio for Bionic twice, then tried instead for Xenial. All reproduced the same problem

Has someone else seen this problem? I can find no other documentation of someone who cannot highlight and copy text in the scripting window. This does not happen in the Console.

Thanks in advance

R version 3.6.1 (2019-07-05)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 18.04.3 LTS

Hi @tkarasov! Welcome!

To help others figure out what might be going wrong, can you confirm what version of RStudio you have installed?

Also, this is a bit of a shot in the dark, but have you tried any of the steps in the RStudio Desktop Troubleshooting Guide, such as resetting RStudio Desktop's state?

Hi jcblum,
Problem solved! Resetting the Desktop state (removing the ~/.rstudio-desktop).
thanks for the help!

rstudio version: rstudio-1.2.1335-amd64

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.