Blank, unresponsive terminal pane, no cursor

Hi there,

I am unable to open the Terminal in RStudio (Windows, Desktop).

At first it would open, but no cursor, and would not accept inputs.

There is a Github issue listed here where it recommends installing the latest Daily Build version.

I did so, installing Version 1.3.745, but now if I try to open a terminal in RStudio I get:


Under Terminal diagnostics I receive this:

Global Terminal Information
Loaded TerminalSessions: 1
Handle: '1DF733A9' Caption: 'Terminal 1'

Terminal List Count: 1
Handle: '1DF733A9' Caption: 'Terminal 1' Session Created: true

Current Terminal Session Information
Caption:     'Terminal 1'
Title:       ''
Cols x Rows  '117 x 12'
Shell:       'Git Bash'
Handle:      '1DF733A9'
Sequence:    '1'
Restarted:   'true
Busy:        'true'
Exit Code:   'null'
Full screen: 'client=false/server=false'
Zombie:      'false'
Track Env    'false'
Local-echo:  'false'
Working Dir: 'Default'
Interactive: 'Always'
WebSockets:  'true'

Current Terminal Emulator Settings
bellStyle: sound
cursorStyle: block
fontFamily: "Lucida Console", monospace
fontWeight: normal
fontWeightBold: bold
rendererType: canvas
allowTransparency: false
cancelEvents: false
convertEol: false
cursorBlink: true
disableStdin: false
drawBoldTextInBrightColors: true
macOptionClickForcesSelection: false
macOptionIsMeta: false
rightClickSelectsWord: false
screenReaderMode: false
windowsMode: true
fontSize: 19
letterSpacing: 0
lineHeight: 1
tabStopWidth: 8
scrollback: 1000

System Information
Desktop:    'true'
Remote:     'false'
Platform:   'Windows'

Connection Information
2020/1/16 18:58:23: Connect WebSocket: 'ws://'
2020/1/16 18:58:23: WebSocket connected
2020/1/16 18:58:24: Disconnected
2020/1/16 18:58:24: WebSocket closed

Local-echo Match Failures
<Not applicable>

It seems this issue has arisen for other users over the past 2 years or so, but I can't find a concrete fix anywhere.

Any advice?

Sorry to hear you are having trouble with this.

As a troubleshooting experiment to help narrow down the problem, can you try switching to Command Prompt instead of Git Bash, and see if you can start a terminal that way?

Tools / Global Options / Terminal, "New terminals open with:" Command Prompt

Then try and open a new terminal in RStudio and share the results.

Hi Gary,

Hmm yes that is something I tried earlier; doing so now results in the same error:

Hitting OK on that dialog and then hitting Enter at the Terminal results in this:

Ok, so that eliminates git-bash as the underlying issue. Are you using Windows-10?

In the global options for the terminal, try disabling the use of websockets.

Same result when I try that :frowning:

It's my work PC, and they have purchased continued support for Windows 7 (Enterprise).
They plan on upgrading us to Windows 10, but are reticent as to when that will happen, so for now I'm stuck with 7 :frowning: :pensive:
I had hoped that was not the root of this problem

RStudio 1.1 and 1.2 do support Windows 7 and the terminal does work on it (normally).

I will do more research and get back to you. My guess is a DLL is missing that is needed by a component we use on Windows.

1 Like

That's what I thought!
Thanks so much Gary

FYI; I tried uninstalling and then re-installing both R and RStudio.
But the problem persists.

Re-installed Versions:
R version 3.6.2 (2019-12-12) -- "Dark and Stormy Night"
RStudio Version 1.3.745

Ok. Haven't made progress on my end, either, but haven't forgotten and will keep investigating.

1 Like

No worries, thanks Gary.
My workplace is upgrading our PCs to Windows 10 on Thursday so I'm hoping after I've re-installed Rstudio with the new operating system the problem will be gone... will let you know.

Great, keep me posted. I've been sick so am even less efficient than usual at getting to things.

That sucks Gary no problem, hope you're feeling better soon :+1:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.