app fails to load when deployed: logs could not find function "get_quosure"

I have 5 different versions of the same code as different shinyapps deployed. 4 of them run fine. Today one stopped loading for the users using it. The logs have an error related a function "get_quosure" which appears to be stopping a reactivevalue variable from being defined.

After scratching my head for a bit I decided to simply download one of the working versions and redploy it in place of the app that stopped working. Yet it still errors exactly the same.

I downloaded it and ran it locally, works every time. I uploaded it as if it was a completly new app to a new name and had removed the rsconnect folder, and it still gives the same error.

My worry now is the the other version that are still running OK suddenly come down with same issue. I have no idea how I'd get them running again, nor why it's happened in the first place.


Hi, I've run into the same issue, my app works fine from Rstudio (docker based rocker/tidyverse:latest) but I get this get_quosure error when I run the application on rocker/shinyverse. I've still to verify I have all the same libraries loaded but I get no errors suggesting libraries are fdailing to load on the shiny server. I have found this link but I don't know what that means, or how to load this utils-lang.R script other than just cutting and pasting!

I have the same problem. Did you manage to find a solution ?

Yes, I did. I had to remove my local version of shiny, and re-install to get the latest version.

I'm not sure why my local version of shiny affected what happened on the shinyapps server , but it worked perfectly afterwards by deploying to shinyapps with the newest version of shiny installed locally.

1 Like

Would you mind posting this as a bug to Shiny’ GitHub issues page, along with any information you can to help folks replicate the error?

We’d like to get additional information on how the error arises.

1 Like

Thank you very much for the quick response. It worked for me too! You helped me a lot. :slight_smile:

I also don't understand why the problem occurred and why this is the solution, but at the moment all that matters to me is that it works.

1 Like

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.