Yaml load error using rMarkdown

I receive the same yaml.load error when I try to knit the rMarkdown and rNotebook stubs (i.e., no mods made to the files by me):

Error in yaml::yaml.load(..., eval.expr = TRUE) :
unused argument (eval.expr = TRUE)
Calls: ... parse_yaml_front_matter -> yaml_load ->
Execution halted

I have tried reinstalling yaml, as per the directions in Error in RMarkdown knit yaml - #11 by anfal. After I reinstalled yaml, answering "y" to the question, "Do you want to install from sources the package which needs compilation?", the following error appeared:

xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
ERROR: compilation failed for package ‘yaml’

  • removing ‘/Users/lewgutman/Library/R/3.3/library/yaml’

If I click "n" to the reinstall question, I receive the same yaml.load error.

Other solutions offered by the community topic above also yielded the same yaml.load error.

I have the latest version of rStudio loaded on my Mac (OS X 10.12.6) and am just learning how to use rStudio. Thanks in advance for any solutions.

This means that you need to install Xcode Command Line Tools.

You should be able to install that by running xcode-select --install in your terminal.


Thank you! It works now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.