xelatex fail to show characters in rmarkdown

when my text has symbols like ( alpha , Beta .. ) they don't appear when I knit pdf, but they do when the output is HTML or anything else. I tried using xelatex or Luatex as latex_engine but didn't work as well. does any one have the same issue ? this is what I used:

title: "FILE_NEW"
   number_sections: yes
   latex_engine: xelatex
  word_document: default
    df_print: paged
toc: yes
toc-depth: 10


# Background

I really don't know why symbols don't appear when I knit pdf, this is an example:
IL-1β , IFN-γ

I'd cut and paste it but Rmd doesn't place nicely with the discourse rendering engine

Screen Shot 2020-04-04 at 8.18.54 PM

not working, specially in case I copy and paste from another source which has a lot of these characters, I figured that's the only way to do so is changing the mainfont

Many, but not all, \LaTeX characters work with the default latex-engine set in the global or projects options.

Untitled.pdf (74.6 KB)

that's right, I tried both pdfLatex and xelatex engines and didn't work, but I think I need some greek font package to support Latex better, at least foe some special characters maybe.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.