Works in RStudio IDE but not in RStudio Cloud

The following code, works perfectly in RStudio IDE but not in my RStudio Cloud project:

chol <-

visualizar por tratamiento (columnas)

tratamientos <- chol %>%
group_by(trt) %>%
mutate(n = row_number()) %>% # para crear valores únicos no lista
pivot_wider(names_from = trt,
values_from = response)

Here is the error:
Error: n() must only be used inside dplyr verbs.


Denny S.

Maybe your package versions are not the same in both places (a key aspect for reproducibility).

To help us help you, could you please prepare a reproducible example (reprex) illustrating your issue? Please have a look at this guide, to see how to create one:

A link to your RStudio Cloud project (with access permissions) would be helpful too.

Thank you Andrés for your quick response. Here is the link to the RStudio Cloud project with the issue:

The name of the specific project is anova


solved: restarting R solved the situation in RStudio Cloud. Thanks

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.