where to find required version of rsconnect for deploying shiny app

I'm trying to deploy/publish my first shiny app using RStudio. I used this code to install rsconnect:



When i click to 'publish application' it tells me rsconnect 0.8.5 is required but 0.7 is available. I've tried going online to download the required version manually and put it into my library folder. All the downloads i've tried have resulted in error messages in the RStudio console.

Does anyone know where/how I can get the version it's asking for?

Hi @Allerious! Welcome!

rsconnect version 0.7 is over 2 years old (you can see when the different versions made it to CRAN on the package source archive page). If that's the only version that is available when you run install.packages(), then my first guess is that perhaps you are using a rather old version of R?

Can you post the output of running sessionInfo()?

Unless you've got a specific reason for running an old version of R, your best option is probably to upgrade R (new major versions are released every year, and it's generally a good idea to stay current while you're developing apps).

Warning: upgrading R will also mean re-installing all your packages. If your R was pretty. old, then some packages may install with substantially newer versions, so you'll also need to test your app to make sure that everything still works!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.