When I install RTools, RStudio stops working

Hi everyone,

I have tried to install RTools, and RStudio stop working when it's installed... It freezes at launching : the loading never ends... I have the good version of RTools : I tried RTools 3.5 for R 3.6.3 and RTools 4 for R 4.03. RStudio stop working when RTools is installed, regardless of the version. And when I uninstall RTools from Windows, RStudio works again...

Now I'm on R 3.6.3, RStudio 1.4.1103 and Windows 10.

An idea what happens ?

Thanks !


More informations :

R launches when Rtools is installed, but it doesn't seems to work. I have installed the package pkgbuild to detect if rtools is well installed in R. When I run has_rtools() to determine if Rtools is installed, R never ends to load (like RStudio). Moreover, R opens a window of windows explorer (??). RStudio do the same thing when I launch it, what is not normal I presume.

When i installed Rtools for the first time on R 4.0, I executed this line in RStudio : writeLines('PATH="${RTOOLS40_HOME}\\usr\\bin;${PATH}"', con = "~/.Renviron") as it is mentionned on the website. Since that, it crashes. Maybe it was not appropriate ?

I don't know what happens, but I feel something is deeply wrong in my installation : the problem stays the same if I completely uninstall et reinstall R, RStudio and Rtools, and R 4.0 doesn't work at all (I can't install any package), it's why i'm still on R 3.6.3...

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.