What to do if "non-zero exit status" when installing package?

Anyone who knows how to solve this problem?

For Mac

install.packages("/users/frederikpieters/Desktop/EconometricsUGent_1.0.tar.gz", type="source", repos = NULL)
Warning: invalid package ‘/users/frederikpieters/Desktop/EconometricsUGent_1.0.tar.gz’
Error: ERROR: no packages specified
Warning in install.packages :
installation of package ‘/users/frederikpieters/Desktop/EconometricsUGent_1.0.tar.gz’ had non-zero exit status

Hi @margggggg (@FrederikP): What happened when you tried this?

There are two possibilities:

  1. You don't have XCode and its command line tools installed. Go to the App Store and download the free XCode app and then, from the terminal enter
xcode-select -p
  1. Even if you have XCode and the command line tools, it may fail anyway. This is because Apple has a non-standard compiler. If this is the case, in 7-10s, in normal times, St. Simon Urbanek of the R Core Team, will edit the source code and post a MAC binary. If you get a non-zero exit error the first time (it sometimes works all right), either wait or if you get the "binary ... but source is later" respond no.

It worked fine, I found the packages and they were operational in RStudio, but a little further on I bounced into this problem :roll_eyes: , thanks for the help on the first topic!

1 Like

Oh, is this a special package given to you by the university?

Yes, it is! As the name says

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.