Warning: Error in loadNamespace: there is no package called ‘markdown’

I am recently deploying my shiny app on Shinyapps.io. But I got the following error:

Warning: Error in loadNamespace: there is no package called ‘markdown’

I did not use ‘markdown’ in my shiny app. I don't understand why ‘markdown’ package is required.

Thanks a lot.

1 Like

I got the same error and resolved it by adding


to my Shiny app code. Didn't actually install anything else or do anything else.

In the past it must have gotten loaded alongside another package but I'm guessing some update has changed that.

My app started having the same issue too and I am not using library(markdown), instead I am using library(rmarkdown).

The reason you did not have to install anything was because you had the package installed.
I say that because when you use library(markdown) and package is not install, RStudio will prompt you to install it.

I was prompted, installed markdown package, used library(markdown) and went away.


Update: I commented library(markdown) in my application and it is still running on shinyapp.io
Not sure why it is acting that way

Just wanted to share that in early January 2023, I am getting the same error, and adding the library(markdown) to my ui.R file resolves.

I can confirm this still occurs when deploying an app on May 2024.

I too find the fix is still adding library(markdown) to my app.R.

In my case, it appears that the markdown package is autoloaded when my app runs by virtue of a call to shiny::includeMarkdown

Apparently, renv magic does not figure this out. Why? Probably answered by a close reading of the renv FAQ.