View() shows blank pane in RStudio Desktop Pro 2023.06.2

I installed RStudio Desktop Pro version 2023.06.2 yesterday, and now when I use View() I get a blank pane. Anyone else experiencing this?

To repro: Open RStudio, run

> x<-data.frame(x=runif(50))
> View(x)

... observe that you get a blank pane showing no data. The same thing happens if I click on the x object in the environment pane.

sessionInfo() is as follows:

> sessionInfo()
R version 4.3.1 (2023-06-16)
Platform: aarch64-apple-darwin20 (64-bit)
Running under: macOS Monterey 12.6.8

Matrix products: default
BLAS:   /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib 
LAPACK: /Library/Frameworks/R.framework/Versions/4.3-arm64/Resources/lib/libRlapack.dylib;  LAPACK version 3.11.0

[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

time zone: America/Los_Angeles
tzcode source: internal

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_4.3.1 tools_4.3.1   

Today I actualize and everything it´s OK. Perhaps:
Reset the computer and try again
or control button and click RStudio, opens other Versions that you installed before.

What finally worked was deleting the RStudio app and reinstalling it. It was the same version, so I don't know why this should have any effect, but my problem is solved.

Great! thanks for sharing how you resolved it.

Reinstalling didn't work for me, but tweaking a line of code did work (I can't take the credit for this solution but figured I'd post it here).

sed -i.bak 's/?? /== undefined ? maxRows : parsedLocation./'  /Applications/
1 Like

@actuaryal What version of R, RStudio, and MacOS are you using?

R: 4.3.1, RStudio: 023.06.2+561.pro5, MacOS: Ventura 13.5.2 (22G91)

1 Like

Thanks for the workaround! This is helpful to investigate. Out of curiosity, where did you find this workaround?

Thanks! I filed this as issue 13624 in the RStudio open source repo. You can follow any progress on there.

We have a fix for this in build 2023.09.0+440 of the release that we're currently working on. We haven't been able to reproduce the problem internally, though. Would any of you be willing to try it out? Please note that these builds are for test and development purposes only, not production use.

RStudio 2023.09.0+463 Desert Sunflower is now live as the official release. If you install it, please let us know in the bug report for it or here if this is working for you. Thanks!