Version 1.1.456 is extremely slow on ubuntu LTS 18.04


I am using RStudio for years now, but with the newest version I am having performance issues:
If I make any click inside the Viewer (I don't have even to try to scroll) one CPU is immediately loaded by 100%, lasting for several seconds, slowing down every next movement inside RStudio, e.g. if I would like to type something in the console, or scrolling inside the Viewer. This is independent of the size of data set from the global environment.

I have the following setting:

platform x86_64-pc-linux-gnu
arch x86_64
os linux-gnu
system x86_64, linux-gnu
major 3
minor 5.1
year 2018
month 07
day 02
svn rev 74947
language R
version.string R version 3.5.1 (2018-07-02)
nickname Feather Spray

RStudio Version 1.1.456

Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic

Option 'index source files' turned off.

Any suggestions how to solve the issue except for downgrading? I haven't found anything on the Rstudio community pages so far.

Thank you!

I can share similar experience on 18.04. At home I have 17.10 and RStudio works great. At work I have 18.04 and specifically Git window is REALLY slow. I don't have CPU throttling, but it takes 2-3 seconds after I choose file in commit window for it to appear in the preview.

Not sure if that's part of the same problem.

R version and RStudio version is the same.


I had this slow-git-window problem in an other, earlier version of RStudio (1.0.xx?), but otherwise that RStudio was working very smoothly. In this version (1.1.456), I didn't even come to the point to test the git window (and I am using command line anyways) because the Viewer windows consumes all my CPU, so that there is no point in working with this RStudio at the moment.

Is there anyone who has any suggestion how to tackle down, what causes this high CPU consumption if using the Viewer window?


Is the situation any better in the preview release of RStudio?

I have down-graded now on 1.0.153 because I needed a working RStudio asap. Along with it the libgstreamer had to be downgraded, too, and with this setting - old RStudio, old libgstreamer - everything works perfectly. Nothing else has changed on the software side, so its either the libgstreamer, the RStudio >1.0.153 or the combination of it.

As soon as our admin has a little time left we will try the newest release, as you suggested.

Good news and bad news :slight_smile:

Good news is that Git window works great. Another thing that was fixed that I didn't mention is flickering scroll bar in code editor. I have "Allow scroll past end of document" enabled and in previous version scroll bar was going crazy whenever I did scroll past it. Now it works.

Bad news is that now scaling is broken. On big monitor I need to zoom in to see the text in code editor, but menu text is extremely small (and it doesn't change with zooming in/out). However, on my laptop monitor text in code editor is large and I need to zoom out to actually see anything. Menu text is fine though.

So you win some, you lose some :slight_smile:. I'll stick with preview for now. I can live with small/big text, but git window slowness was a real flow killer.

Do you have global UI scaling turned up? If menus are small, that would be a property of the default styling for the system themes. Do you see small menus for other applications?

The ultimate truth here is that handling of high DPI displays is a quagmire on Linux and Windows, and is even more of a mess when you bring multiple, mixed-DPI displays into the mix. At least for me, when I use GNOME 3 and attempt to set 200% scaling on my high DPI display, most applications have their UI elements inconsistently sized. That is, it's not an issue unique to RStudio.

I've checked with Slack, Firefox, DataGrip, Sublime Text and Thunderbird and they all have correct size for menus on both monitors. So, not sure if there is anything wrong with RStudio or there is something else at play.
But like I've said, it's a minor issue compared to git slowness, so I'll be sticking with 1.2 preview version.

As you suggested I tested the newest, preview release version.
The situation is a little better, but in general very bad. As soon as I do anything, e.g. typing int he console, the CPU load is far too high. Here is a screenshot of my CPUload:

On the left side the busy CPU is me typing in the console in RStudio, on the right side, the far less busy CPU, is me typing in an ordinary editor.
In summary: the newest RStudio version is still unusable for me.

Is there any possibility how I could check, why the CPU load is so high? Any suggestions?


One thing I'm curious of: is it the R session process (rsession) that's using CPU, or the RStudio front-end (rstudio) that's causing this slowness?

We could try attaching a profiler to RStudio to figure out what it's doing at this point in time. Since you're using Linux, you could try the perf utility. Some steps:

  1. Start RStudio,
  2. Open a new terminal,
  3. In the terminal, execute sudo perf record -p $(pidof rstudio),
  4. Perform some actions in the IDE that cause the heavy CPU usage,
  5. Stop the profiler with e.g. Ctrl + C in the terminal,
  6. Run perf report --stdio to generate a performance report.

You can try the same steps for rsession if nothing useful comes from recording the rstudio process.

Are you by any chance working with a Git-managed project containing a very large number of branches? We've discovered one issue that can cause the IDE to hang for a couple seconds when the window is focused in some cases:

Hi Kevin,

it was definitely not a problem of git-managed project, git is still not installed on the computer. I am writing 'was', because after installing an other program, which required a long list of additional libraries - among them java-libs - the prelease version shows now normal CPU-load, as well in the console during typing, as in the Viewer window. I cannot even reconstruct, if it was an additional library which solved the problem, or the second reboot after installing, or whatever. Unfortunately, I also don't have the time to turn everything back just to check. Main message: it is working now!

Thanks for your suggestions!

1 Like

Hi Solveig,
I am experiencing the same problems as you and I am wondering what programme you installed that solved the problem. It might give me a hint which java-libs are missing on my machine.

Also: Hi Kevin!
May I ask which java-libs are recommended to run Rstudio properly on ubuntu 18.04?


no sorry, I can't help you here, I had to switch the compi again since then and have even less possibilities to reproduce the issue. As a wild guess, the missing libraries I installed later could have come either with java and/or with TexStudio. I think all other packages I installed after RStudio have less probability to have the one crucial library as dependency.
So, from my side I can only wish you good luck with searching the needle in the haystack :slightly_frowning_face:


RStudio itself does not require Java or a JRE, although some packages used by R (e.g. rJava) do. So that may be a red herring.