Urgent Help Needed: Unable to Install RStudio Update - "RStudio is currently running" Error

Dear Community,

I'm in a difficult situation right now and I'm really hoping someone can offer some assistance. I'm facing a frustrating issue while trying to update RStudio, and it's been causing me a lot of stress. Every time I try to install the update, I'm greeted with the discouraging message "RStudio is currently running. Please close it before installing a new version," even though I've made sure that there are no instances of RStudio running on my system.

I've tried everything I can think of to fix this issue:

  1. I've rebooted my system multiple times to make sure no hidden processes are running.
  2. I've meticulously checked the Task Manager to ensure no trace of RStudio is active.
  3. I've scoured my system to remove any leftover RStudio files or folders.
  4. I even attempted to install a previous version of RStudio and update from there, but I hit roadblocks with installation errors.

Despite my best efforts, the problem persists, and I'm feeling really overwhelmed. If anyone has any experience with a similar issue or any suggestions on how I can resolve this, I would be immensely grateful for your help.

Please, if anyone can offer assistance, it would mean the world to me. Thank you so much for taking the time to read this.

Warm regards,

Hi @EdenJung, welcome to the forum!

This sounds strangely familiar to this post...did you rename the installer by any chance?


Hi, I didn't change it at all. I haven't even tried.

@randyzwitch I saw the post you uploaded and tried changing the installer file name to 'rstudioinstaller.exe', but the same error occurs. ("RStudio is currently running. Please close it before installing a new version.")

The only other thing I can think of would be if RStudio is set to launch on startup. I don't have a Windows computer handy, but can you check to see if RStudio happens to be in that list?

I don't know that this could explain the "currently running" message, but you might try resetting the RStudio desktop state as described here.


@randyzwitch I haven't designated anything as a startup program. Additionally, RStudio is not currently installed on my computer. (I uninstalled it because the installation failed repeatedly due to a 'currently running' error during update attempts.)

Dear @prubin, Thank you so much. By referring to the 'Resetting RStudio Desktop's State' method you mentioned, I was able to find the %appdata%\RStudio folder and delete it, and now the installation file works properly. (I couldn't find the folder when I tried using other methods like searching manually or using File Explorer.) I urgently needed to use RStudio, so this was a critical situation. You really saved me. I am truly grateful!!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.