Updated RStudio, now all RMDs are blank

Error Information:

Description of issue -
Updated RStudio (RStudio-2022.07.2-576.) and now when I open my rmd files they appear blank (the code that used to be in them it is not there anymore). This was also an issue with "old" R scripts, when I open them they are "blank"
ETA - It seems like the "blank" rmd's are those that are older than a year. Any ideas?

Steps taken so far -

I tried using this fix (Tools > Global Options> Code > Saving > UTF-8), but didn't work.

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 022.07.2 Build 576
  • OS Version: "Spotted Wakerobin" Release (e7373ef8, 2022-09-06) for macOS
  • R Version: R version 4.2.0 (2022-04-22) -- "Vigorous Calisthenics"
    Copyright (C) 2022 The R Foundation for Statistical Computing
    Platform: x86_64-apple-darwin17.0 (64-bit)


  • RStudio diagnostics report:
  • Your sessionInfo():
  • RStudio crash report:
  • RStudio application log files:

From Troubleshooting Guide: Using RStudio

What happens if you open a .rmd fIile in a text editor such as gedit or Notepad?

@salsarita We've seen a couple of similar issues in the past, but that was were on Windows, so they might not be the same. Are you saving on a local or remote/shared drive?

(The other issues were 1623 and 11206, if you're curious.]

I figured it out, it was the shared drive it was not connecting/downloading the file so when I opened it it was blank. Once I fixed the shared drive situation it was fine! Should have updated my bad!

No problem—I'm glad it worked out!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.