updated my MAC and RStudio won't start

Error Information:

Description of issue - R Studion will not start after an update to Mac

Attempted steps taken to fix -

System Information:

  • RStudio Edition: (Desktop)
  • RStudio Version: 1.4
  • OS Version: Catlina 10.15.7 (19H1519)
  • R Version:
  • Output your diagnostics report (if possible):

From RStudio Desktop Will Not Start on support.rstudio.com

Any idea?
I have the same problem


I use this code on Terminal

defaults write com.rstudio.desktop $'desktop\xb7renderingEngine' 'software'

After a few seconds, Rstudio will run again


Thank you Jya that works

Thanks. That worked for me as well.

I used that command in my MacBook Pro (13-inch, Mid 2012) with macOS Catalina version 10.15.7 (19H1519) and it works!!! Thank you very much!

sorry where do i put this code in? im having the same issue

the app won't open at all to even show the terminal just an error message showing that rsudio quit unexpectedly


You have tu use it in the mac Terminal application


Thank you jya, you save me...
It works!

Thank you. I had the exact same problem, and this fixed it. Why did it fix it?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.