Updated CRAN Shiny App Not Working


I recently updated a CRAN package I made which is a shiny app called MDMAPR.

When I ran the packaged version of my app of my computer for testing everything was working perfectly. I put the new updated version of my app on CRAN as well.

I downloaded the updated version of my CRAN package to my computer and then tried to run it but I ended up getting this error.

"Couldn't normalize path in addResourcePath, with arguments: prefix = 'htmlwidgets-1.5.3'; directoryPath = '/Volumes/Builds/packages/high-sierra-x86_64/Rlib/4.0/htmlwidgets/www'"

htmlwidgets is not even referenced in my app. I did update my packages versions on my machine but i do not know how to fix this error.

Has anyone encountered this error before?

Perhaps not directly but if you use other packages they may have it as a dependency. I recommend using renv to keep track of dependencied

Does that mean I should load the htmlwidgets library into my package?

There's no guarantee, but it would seem a low effort thing to try.

Adding the library to my package fixed the problem for me.

Thank you for your help @nirgrahamuk!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.