Update RStudio (now version 1.4.1103) with R Version 3.5.3 leads to error when installing tidyverse

Hello Community! :slight_smile:

My Laptop had to be newly installed and now I am running the newest RStudio version (1.4.1103) with my previosly used R version 3.5.3. When trying to load the newly installed tidyverse package, I run into several errors:

  1. When executing library(tidyverse) an error message tells me:

Fehler: package or namespace load failed for ‘tidyverse’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
es gibt kein Paket namens ‘broom’

(sorry its german, but the last message would mean: 'There is no package called 'broom')

  1. I tried to install broom seperately then and run into the following error:

Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) :
namespace 'dplyr' 0.8.5 is being loaded, but >= 1.0.0 is required
ERROR: lazy loading failed for package 'broom'

  • removing 'C:/Users/blochc/Documents/R/R-3.5.3/library/broom'

So I think the problem in tidyverse is that broom could not be installed adequately? Does someone know this problem? Could the R version be too old?

Thanks so much for your help!


The error that you're getting when you install broom seems like it's saying that dplyr needs to be updated. It looks like the broom package depends on version 1.0.0 of dplyr, but you have version 0.8.5.

Have you tried re-installing dplyr to get the newer version, and then installing broom again?

1 Like

Update dplyr

1 Like

Thanks a lot for your suggestions! That helped a lot!

I tried updating dplyr, but it always loaded version 0.8.5.

I updated R now to the newest version (4.0.3) and tidyverse was installed and loaded without a problem. So I suggest that my old R version 3.5.3 was not compatible with the newest dplyr versions anymore which led to the fail of installing broom and tidyverse adequately (?)


1 Like

That seems like a reasonable guess! I'm glad you got it working.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.